Bug 493266 - Anaconda fails on fstab with bind mount
Anaconda fails on fstab with bind mount
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:8c499aaa131ab9659...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 03:43 EDT by Andrew Bartlett
Modified: 2009-08-27 12:38 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 10:01:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (284.71 KB, text/plain)
2009-04-01 03:43 EDT, Andrew Bartlett
no flags Details
Attached traceback automatically from anaconda. (176.36 KB, text/plain)
2009-04-03 06:10 EDT, Braden McDaniel
no flags Details
Attached traceback automatically from anaconda. (121.50 KB, text/plain)
2009-04-05 23:37 EDT, Tom Gutwin
no flags Details
Attached traceback automatically from anaconda. (168.17 KB, text/plain)
2009-04-14 11:56 EDT, panathcypan
no flags Details
Attached traceback automatically from anaconda. (191.16 KB, text/plain)
2009-04-15 16:00 EDT, Edwin Schepers
no flags Details
Attached traceback automatically from anaconda. (166.61 KB, text/plain)
2009-04-25 10:40 EDT, Bruce Luckcuck
no flags Details
Attached traceback automatically from anaconda. (161.88 KB, text/plain)
2009-06-20 06:58 EDT, 18niceboy18
no flags Details
Attached traceback automatically from anaconda. (122.77 KB, text/plain)
2009-08-27 12:38 EDT, Gerald Rezes
no flags Details

  None (edit)
Description Andrew Bartlett 2009-04-01 03:43:38 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/__init__.py", line 1346, in parseFSTab
    raise Exception("fstab entry %s is malformed: %s" % (devspec, e))
  File "/usr/lib/anaconda/storage/__init__.py", line 958, in mountExistingSystem
    fsset.parseFSTab(chroot=rootPath)
  File "/usr/lib/anaconda/upgrade.py", line 236, in upgradeMountFilesystems
    allowDirty = 0)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
Exception: fstab entry /scratch/kvm is malformed: get_containing_device() takes exactly 2 arguments (1 given)
Comment 1 Andrew Bartlett 2009-04-01 03:43:49 EDT
Created attachment 337460 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-04-01 10:34:00 EDT
Thanks for the bug report.  This will be fixed in the next build of anaconda.
Comment 3 Chris Lumens 2009-04-01 10:46:13 EDT
That wasn't the resolution I wanted.
Comment 4 Braden McDaniel 2009-04-03 06:10:03 EDT
Created attachment 338011 [details]
Attached traceback automatically from anaconda.
Comment 5 Tom Gutwin 2009-04-05 23:37:31 EDT
Created attachment 338280 [details]
Attached traceback automatically from anaconda.
Comment 6 panathcypan 2009-04-14 11:56:22 EDT
Created attachment 339518 [details]
Attached traceback automatically from anaconda.
Comment 7 Edwin Schepers 2009-04-15 16:00:05 EDT
Created attachment 339737 [details]
Attached traceback automatically from anaconda.
Comment 8 Bruce Luckcuck 2009-04-25 10:40:27 EDT
Created attachment 341318 [details]
Attached traceback automatically from anaconda.
Comment 9 Braden McDaniel 2009-04-29 01:50:48 EDT
This is not fixed.  I've encountered the same problem with F11 Preview.
Comment 10 Chris Lumens 2009-04-29 10:01:29 EDT
This was fixed in anaconda-11.5.0.48 which unfortunately was not included in the preview release.
Comment 11 Bruce Luckcuck 2009-04-29 14:25:55 EDT
In my case the failure was apparently caused by an entry in fstab that was part of VMWare tools:

In /etc/fstab:

# Beginning of the block added by the VMware software
.host:/                 /mnt/hgfs               vmhgfs  defaults,ttl=5     0 0
# End of the block added by the VMware software

Simply commenting out the ".host:/" line allowed the FC11beta to install without problems and upgrade my FC10 (virtual) instance.
Comment 12 18niceboy18 2009-06-20 06:58:28 EDT
Created attachment 348741 [details]
Attached traceback automatically from anaconda.
Comment 13 Gerald Rezes 2009-08-27 12:38:43 EDT
Created attachment 358909 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.