This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 49332 - rpm incorrectly compares versions
rpm incorrectly compares versions
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-17 23:49 EDT by Jim Radford
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-21 12:56:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Radford 2001-07-17 23:49:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
rpm doesn't think 4.0.0pre10 is greater than 3.1.17-14.


How reproducible:
Always

Steps to Reproduce:
$ rpm -q autofs
autofs-3.1.7-14
$ rpm -U --test autofs-4.0.0pre10-1.i386.rpm
package autofs-3.1.7-14 (which is newer than autofs-4.0.0pre10-1) is 
already installed


Additional info:

You can get get a copy of my autofs rpm in case you want to try it 
yourself at:

http://robotics.caltech.edu/~radford/autofs-4.0.0pre10-1.i386.rpm
http://robotics.caltech.edu/~radford/autofs-4.0.0pre10-1.src.rpm

NOTE that long after the bug has been reported --test still runs
scripts.  Make you nervous?  Me too!
Comment 1 Michael Schwendt 2001-07-21 12:56:19 EDT
$ rpm -q --qf "%{SERIAL}\n" autofs
1
$ rpm -qp --qf "%{SERIAL}\n" autofs-4.0.0pre10-1.i386.rpm
(none)

Not a bug, and will be reported many more times most likely. :)
Comment 2 Jeff Johnson 2001-07-21 15:26:48 EDT
Check for an epoch in the autofs-3.1.17-14 package:

rpm -q --qf '%{name}-%{version}-%{release} has epoch %{epoch}' autofs-3.1.17-14.

If that has an epoch, then you need to add an epoch tp the autofs-4.0.0.pre10
package.

Note You need to log in before you can comment on or make changes to this bug.