Bug 493351 - yum fails with traceback when cleaning up nfs-utils
yum fails with traceback when cleaning up nfs-utils
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 10:34 EDT by Tomáš Bžatek
Modified: 2015-03-03 17:40 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 10:42:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomáš Bžatek 2009-04-01 10:34:49 EDT
Description of problem:
at the time of fail, I was updating pre-beta rawhide to post-beta, excluding kernel, pango, freetype and some other packages... i.e. not complete upgrade. However dependency resolution succeeded.

Version-Release number of selected component (if applicable):
yum-3.2.21-12.fc11.noarch
yum-3.2.22-1.fc11.noarch  (both installed at the same time?)
PackageKit-0.4.6-1.fc11.x86_64

How reproducible:
Only during this upgrade, haven't tested again

Steps to Reproduce:
1. Run gpk-update-viewer, select updates, Apply
2. Dependency check phase completes successfully
3. Upgrade phase completes successfully
4. during cleanup of nfs-utils, error message is displayed
  

Actual results:

Error Type: <type 'exceptions.TypeError'>
Error Value: string indices must be integers, not str
  File : /usr/lib/python2.6/site-packages/yum/rpmtrans.py, line 389, in callback
    self._scriptError(bytes, total, h)
  File : /usr/lib/python2.6/site-packages/yum/rpmtrans.py, line 510, in _scriptError
    remove_hdr = False # if we're in a clean up/remove then hdr will not be an rpm.hdr
  File : /usr/lib/python2.6/site-packages/yum/rpmtrans.py, line 237, in _dopkgtup
    tmpepoch = hdr['epoch']
Comment 1 seth vidal 2009-04-01 10:42:15 EDT
This is fixed in yum 3.2.22 which is in rawhide.
Comment 2 James Antill 2009-04-01 10:59:07 EDT
you probably want to run:

 package-cleanup --cleandupes

...to make sure you just have 3.2.22 installed.

Note You need to log in before you can comment on or make changes to this bug.