This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 493369 - Synaptics touchpad tapbutton doesn't work
Synaptics touchpad tapbutton doesn't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 11:27 EDT by Edouard Bourguignon
Modified: 2009-04-15 02:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 02:53:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my Xorg.0.log (13.95 KB, text/plain)
2009-04-01 11:30 EDT, Edouard Bourguignon
no flags Details

  None (edit)
Description Edouard Bourguignon 2009-04-01 11:27:58 EDT
Description of problem:
Tapbutton doesn't work at all, but with xev have to tap 4 or 5times before mouse click occurs. This was working on f10.

Version-Release number of selected component (if applicable):
xorg-x11-drv-synaptics-1.1.0-1.fc11.x86_64
xorg-x11-drv-evdev-2.2.1-1.fc11.x86_64
xorg-x11-server-Xorg-1.6.0-16.fc10.x86_64

How reproducible:
seems static

Steps to Reproduce:
1.try to tap on the touchpad: nothing
1.open xev
2.try to tap on touchpad
3.a lot of taps are missed
  
Actual results:
Tapbuttons doesn't work at all, really annoying

Expected results:
Tapbuttons should work at first tap, should be smooth and reactive.
Comment 1 Edouard Bourguignon 2009-04-01 11:30:16 EDT
Created attachment 337562 [details]
my Xorg.0.log

scrolling with the touchpad is working but not the tap button function for clicking
Comment 2 Peter Hutterer 2009-04-01 18:56:53 EDT
Tapping is disabled by default, see also https://fedoraproject.org/wiki/Features/SynapticsUpdate 

Did you enable it in your configuration or the fdi files?
Comment 3 Edouard Bourguignon 2009-04-02 02:15:53 EDT
oh ok, it's a feature not a bug... will try to re-enable it in the fdi files.
Comment 4 Edouard Bourguignon 2009-04-02 05:09:35 EDT
[edouard@supernovae ~]$ xinput --list-props "SynPS/2 Synaptics TouchPad"
Device 'SynPS/2 Synaptics TouchPad':
	Device Enabled (93):		1
	Synaptics Edges (241):		1632, 0, 5312, 0
	Synaptics Finger (242):		24, 0, 29
	Synaptics Tap Time (243):		180
	Synaptics Tap Move (244):		221
	Synaptics Tap Durations (245):		180, 0, 180
	Synaptics Tap FastTap (246):		0
	Synaptics Middle Button Timeout (247):		75
	Synaptics Two-Finger Pressure (248):		280
	Synaptics Two-Finger Width (249):		7
	Synaptics Scrolling Distance (250):		100, 0
	Synaptics Edge Scrolling (251):		1, 0, 0
	Synaptics Two-Finger Scrolling (252):		0, 0
	Synaptics Move Speed (253):			0.400000
, 	0.000000
, 	0.700000
, 	0.000000

	Synaptics Edge Motion Pressure (254):		29, 0
	Synaptics Edge Motion Speed (255):		1, 0
	Synaptics Edge Motion Always (256):		0
	Synaptics Button Scrolling (257):		1, 1
	Synaptics Button Scrolling Repeat (258):		1, 1
	Synaptics Button Scrolling Time (259):		100
	Synaptics Off (260):		0
	Synaptics Guestmouse Off (261):		0
	Synaptics Locked Drags (262):		0
	Synaptics Locked Drags Timeout (263):		5000
	Synaptics Tap Action (264):		0, 0, 0, 0, 0, 0, 0
	Synaptics Click Action (265):		1, 1, 1
	Synaptics Circular Scrolling (266):		0
	Synaptics Circular Scrolling Distance (267):			0.100000

	Synaptics Circular Scrolling Trigger (268):		0
	Synaptics Circular Pad (269):		0
	Synaptics Palm Detection (270):		0
	Synaptics Palm Dimensions (271):		10, 0
	Synaptics Coasting Speed (272):			0.000000

	Synaptics Pressure Motion (273):		29, 0
	Synaptics Pressure Motion Factor (274):			1.000000
, 	0.000000

	Synaptics Grab Event Device (275):		1

May be you can help me? 
So I try to change the Tap Action value:

xinput --set-int-prop "SynPS/2 Synaptics TouchPad" "Tap Action" 8 2 3 0 0 1 2 3

but doesn't change anything... any idea?
Comment 5 Peter Hutterer 2009-04-05 18:33:52 EDT
Try "Synaptics Tap Action" as property name. The command above would have created a new property, not modified the existing one.
Comment 6 Edouard Bourguignon 2009-04-06 02:46:08 EDT
thanks that seems to work (not perfectly, maybe one tapclick out of 4 is missed). I also tried with gsynaptics which is more user friendly. But this setting is not persistent, will try to modify xorg.conf.
I will close the bug if tap button works perfectly.
Comment 7 Peter Hutterer 2009-04-06 02:50:42 EDT
Try increasing Synaptics Tap Move or Synaptics Tap Time.
Comment 8 Peter Hutterer 2009-04-14 01:05:30 EDT
ping?
Comment 9 Edouard Bourguignon 2009-04-14 03:18:53 EDT
I'm going to try this as soon as possible. I also have a strange behavior with the mouse stick, the mouse cursor get stuck just before (a few pixels) passing over widget like buttons or scroll button. Really annoying too. Is that a synaptics setting?
Comment 10 Peter Hutterer 2009-04-14 19:25:20 EDT
the mouse stick is usually controlled by the evdev driver, it's actually a separate device. I haven't heard of this problem either. It could be acceleration going bad when you slow down to hit a button. If you think this (or something else) is the case, please open a new bug though to keep this one focused on one issue only.
Comment 11 Edouard Bourguignon 2009-04-15 02:53:32 EDT
Ok thanks for your help. Btw the mouse stick seems better now with the latest updates. And for the touchpad I have now a checkbox in the mouse setting to enable the tap click and it's persistent. So cool! I can close this bug.

Note You need to log in before you can comment on or make changes to this bug.