Bug 493393 - Yet another custom partition failing
Yet another custom partition failing
Status: CLOSED DUPLICATE of bug 493361
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:1147b0d1ec5a47be4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 12:14 EDT by Jóhann B. Guðmundsson
Modified: 2009-04-01 12:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 12:42:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (92.17 KB, text/plain)
2009-04-01 12:14 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2009-04-01 12:14:37 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 979, in isExtended
    return self.partType & parted.PARTITION_EXTENDED
  File "/usr/lib/anaconda/storage/devices.py", line 1040, in dependsOn
    if isinstance(dep, PartitionDevice) and dep.isExtended and self.isLogical:
  File "/usr/lib/anaconda/storage/devicetree.py", line 602, in cmpActions
    elif a2.device.dependsOn(a1.device):
  File "/usr/lib/anaconda/storage/devicetree.py", line 647, in processActions
    self._actions.sort(cmp=cmpActions)
  File "/usr/lib/anaconda/storage/__init__.py", line 210, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 115, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
TypeError: unsupported operand type(s) for &: 'NoneType' and 'int'
Comment 1 Jóhann B. Guðmundsson 2009-04-01 12:14:44 EDT
Created attachment 337573 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-04-01 12:42:38 EDT

*** This bug has been marked as a duplicate of bug 493361 ***

Note You need to log in before you can comment on or make changes to this bug.