Bug 493409 - initrd extends beyond end of memory
initrd extends beyond end of memory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 12:51 EDT by Michael J. Chudobiak
Modified: 2009-05-26 03:14 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-30 16:05:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot log output (360.54 KB, image/jpeg)
2009-04-02 07:47 EDT, Michael J. Chudobiak
no flags Details

  None (edit)
Description Michael J. Chudobiak 2009-04-01 12:51:17 EDT
Description of problem: I burned F11-Beta-x86_64-Live.iso to a CD and logged into it fine. Then I installed livecd-tools in the live environment, and used livecd-iso-to-disk (with the iso stored on a 1GB thumb drive) to generate a live thumb drive (an 8GB thumb drive in another slot).

If I try to boot with the successfully-created thumb drive on my HP DC7800, I get this error:

initrd extends beyond end of memory (0x7d2af86d > 0x7d2af000)
disabling initrd

- Mike
Comment 1 Jeremy Katz 2009-04-01 16:46:18 EDT
Can you remove quiet from the boot args and get the entire boot log (captured with a camera is fine)
Comment 2 Michael J. Chudobiak 2009-04-02 07:47:27 EDT
Created attachment 337785 [details]
boot log output

Here is a photo of the console output for the crash.

My hard drive is encrypted. No passphrase was requested during the live-thumb boot process. Perhaps that is the root of the problem, or perhaps it is unrelated.

- Mike
Comment 3 Ed Swierk 2009-04-02 16:48:38 EDT
I get the same error booting F11-Beta-x86_64-Live from a USB flash drive on a Dell Dimension 8400.  I prepared the flash using syslinux-3.73-2.fc11 and livecd-tools-020-1.fc10.

initrd extends beyond end of memory (0x5fe8c86d > 0x5fe8c000)
disabling initrd
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)


When I boot without the quiet command line option, the tail end of the console output shows errors mounting the root filesystem, but I suspect these are just a consequence of the missing initrd:

VFS: Cannot open root device "UUID=E195-87A5" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
0800       732574584 sda driver: sd
  0801           48163 sda1
  0802       732515805 sda2
0810       732574584 sdb driver: sd
  0811       732572001 sdb1
0b00         1048575 sr0 driver: sr
0b01         1048575 sr1 driver: sr
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
Comment 4 Ed Swierk 2009-04-02 17:10:34 EDT
My machine has 1536MB of RAM installed.  The Linux kernel apparently thinks it has ~1534.5MB (0x5fe8c000 / 1024 / 1024).  I can make the problem go away by appending "mem=1534M" to the kernel command line.

My uneducated guess is that syslinux is failing to account for some reserved memory area that the kernel somehow knows about.
Comment 5 Matt Domsch 2009-04-03 13:17:59 EDT
Similar failure for me with a Dell Precision Workstation 370, latest BIOS (A08 from  July 2006), 2GB RAM, and using syslinux from rawhide yesterday syslinux-3.73-2.fc11.  Been seeing this failure for a few weeks now with Fedora 11 LiveUSB images.
Comment 6 Matt Domsch 2009-04-03 13:19:23 EDT
kernel option mem=1600M resolves.
Comment 7 Chuck Ebbert 2009-04-03 17:54:30 EDT
This could be an e820 kernel bug. I added four e820 fixes from 2.6.30 to the F-11 kernel in 2.6.29.1-48 -- could someone see if they make a difference?
Comment 8 H. Peter Anvin 2009-04-22 00:11:59 EDT
I suspect this is a problem when part of the initramfs ends up in a fractional page near the end of memory.  Syslinux 3.75 should fix this.
Comment 9 Jeremy Katz 2009-04-28 15:47:48 EDT
3.75 is in rawhide now and was used for the preview release.  Matt -- can you verify that the preview release is okay?
Comment 10 Matt Domsch 2009-04-30 16:05:13 EDT
Yes, Preview works, no problem.  Closing.
Comment 11 Gerhard 2009-05-22 18:17:37 EDT
I have also the problem with the beta from the 2009/04/23.

### cut begin ###

RAMDISK: Compressed image found at block 0
RAMDISK: incomplete write (-28 != 32768) 16777216
crc error
EXT3-fs: unable to read superblock
EXT4-fs: unable to read superblock
EXT4-fs: Update your userspace programs to mount using ext4
EXT4-fs: ext4dev backwards compatibility will go away by 2.6.31
EXT4-fs: unable to read superblock
isofs_fill_super: bread failed, dev=md2, iso_blknum=16, block=32
List of all partitions:
0800       156290904 sda driver: sd
0b00         1048575 sr0 driver: sr
0b01         1048575 sr1 driver: sr
No filesystem could mount root, tried: ext3 ext4 ext4dev iso9660
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(9,2)

### cut end ###

I've also a HP DC7800 with 2GB RAM, I tried already the mem-option and now no idea what I can do. But maybe one of the genius here have an advice for me.
Comment 12 Matt Domsch 2009-05-22 19:32:07 EDT
Gerhard, try the Preview release instead, or a later snapshot or rawhide.  This was fixed just in time for the Preview release.
Comment 13 Gerhard 2009-05-23 14:39:42 EDT
I also tried the preview release... no difference.
Are there newer (other) versions than the preview version available?
Comment 14 Matt Domsch 2009-05-23 22:50:39 EDT
http://alt.fedoraproject.org/pub/alt/stage/f11-rc0.1/
has a newer snapshot, as of 20-May.
Comment 15 Gerhard 2009-05-26 03:14:20 EDT
Snapshot Works great - thx a lot!

Note You need to log in before you can comment on or make changes to this bug.