Bug 493425 - Sysprof dependency broken for kmod-sysprof >= 1.0.12
Sysprof dependency broken for kmod-sysprof >= 1.0.12
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sysprof (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gianluca Sforna
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 13:42 EDT by Clemens Eisserer
Modified: 2009-04-02 06:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-02 06:08:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clemens Eisserer 2009-04-01 13:42:01 EDT
Description of problem:

Installing sysprof aborts, because kmod-sysprof can not be found:

[root@localhost ce]# yum install sysprof
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package sysprof.i386 0:1.0.12-2.fc11 set to be updated
--> Processing Dependency: kmod-sysprof >= 1.0.12 for package: sysprof
--> Finished Dependency Resolution
sysprof-1.0.12-2.fc11.i386 from rpmfusion-free-rawhide has depsolving problems
  --> Missing Dependency: kmod-sysprof >= 1.0.12 is needed by package sysprof-1.0.12-2.fc11.i386 (rpmfusion-free-rawhide)
Error: Missing Dependency: kmod-sysprof >= 1.0.12 is needed by package sysprof-1.0.12-2.fc11.i386 (rpmfusion-free-rawhide)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest



Version-Release number of selected component (if applicable):
Fedora11-Beta
Comment 1 Hans de Goede 2009-04-02 04:29:20 EDT
I'm hitting this too, or atleast something similar.

The problem is that in rawhide the kernel packages changes so quickly the normal
kmod packages are almost unusable (as they are obsolete as soon as they are build).

The akmod package fixes this, so I did:
[hans@localhost ~]$ sudo yum install akmod-sysprof
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package akmod-sysprof.x86_64 0:1.0.12-1.fc11 set to be updated
--> Processing Dependency: sysprof-kmod-common >= 1.0.12 for package: akmod-sysprof
--> Running transaction check
---> Package sysprof.x86_64 0:1.0.12-2.fc11 set to be updated
--> Processing Dependency: kmod-sysprof >= 1.0.12 for package: sysprof
--> Running transaction check
---> Package kmod-sysprof.x86_64 0:1.0.12-1.fc11 set to be updated

Notice how it still ends up trying to install the normal kmod, which then fails
as there is none for any of my installed kernels.

This is caused by the main / non kmod sysprof package requiring:
kmod-sysprof >= 1.0.12

So its explicitly asking for the normal kmod, it should require:
sysprof-kmod >= 1.0.12

Which is provided by both the regular kmod's and the akmod
Comment 2 Gianluca Sforna 2009-04-02 06:08:36 EDT
1.0.2-4 just build should fix the issue

Note You need to log in before you can comment on or make changes to this bug.