Bug 493437 - gnome-do crash
gnome-do crash
Status: CLOSED DUPLICATE of bug 494132
Product: Fedora
Classification: Fedora
Component: gnome-do (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Sindre Pedersen Bjørdal
Fedora Extras Quality Assurance
:
: 494118 494235 494728 495106 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 14:20 EDT by adriano
Modified: 2009-04-10 14:49 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-04 19:29:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adriano 2009-04-01 14:20:44 EDT
Description of problem:
With the last update of rawhide, running gnome-do from terminal to see error messages, the errors was:
[Error 20:16:57.211] Could not load desktop item: libgnome-desktop-2.so.7
[Error 20:16:57.311] Could not load desktop item: libgnome-desktop-2.so.7

If I try to open Preferences dialog, the application crashes with the following dump:

Marshaling activate signal
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.DllNotFoundException: libgnome-desktop-2.so.7
  at (wrapper managed-to-native) Gnome.DesktopItem:gnome_desktop_item_new_from_uri (intptr,int,intptr&)
  at Gnome.DesktopItem.NewFromUri (System.String uri, DesktopItemLoadFlags flags) [0x00000] 
  at Do.Platform.Linux.SystemService.get_AutoStartFile () [0x00000] 
  at Do.Platform.Linux.SystemService.IsAutoStartEnabled () [0x00000] 
  at Do.UI.GeneralPreferencesWidget.get_AutostartEnabled () [0x00000] 
  at Do.UI.GeneralPreferencesWidget..ctor () [0x00000] 
  at Do.UI.PreferencesWindow..ctor () [0x00000] 
  at Do.Core.Controller.ShowPreferences () [0x00000] 
  at Do.Universe.PreferencesItem.Run () [0x00000] 
  at Do.UI.MainMenu+<MenuItemFromRunnableItem>c__AnonStorey12.<>m__20 (System.Object sender, System.EventArgs e) [0x00000] 
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] 
  --- End of inner exception stack trace ---
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] 
  at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] 
  at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x00000] 
  at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00000] 
  at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000] 
  at GLib.Signal.ClosureInvokedCB (System.Object o, GLib.ClosureInvokedArgs args) [0x00000] 
  at GLib.SignalClosure.Invoke (GLib.ClosureInvokedArgs args) [0x00000] 
  at GLib.SignalClosure.MarshalCallback (IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data) [0x00000] 
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at GLib.SignalClosure.MarshalCallback(IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Do.Do.Main(System.String[] args)


Version-Release number of selected component (if applicable):
gnome-do-0.8.1.3-2.fc11.i586
gnome-desktop-2.26.0-1.fc11.i586
gnome-desktop-sharp-2.24.0-3.fc10.i386

That's all.
Tks
Adriano
Comment 1 Sindre Pedersen Bjørdal 2009-04-01 15:20:04 EDT
I'm guessing this happens because your gnome-desktop-sharp isn't built against your gnome-desktop. Is this rawhide?
Comment 2 adriano 2009-04-02 08:48:12 EDT
(In reply to comment #1)
> I'm guessing this happens because your gnome-desktop-sharp isn't built against
> your gnome-desktop. Is this rawhide?  

Yes, it's rawhide (rawhide update from fedora 11 beta).
Comment 3 Sindre Pedersen Bjørdal 2009-04-04 18:23:09 EDT
*** Bug 494118 has been marked as a duplicate of this bug. ***
Comment 4 Sindre Pedersen Bjørdal 2009-04-04 18:40:06 EDT
I believe this is really an issue with gnome-desktop-sharp not being updated in rawhide yet. gnome-desktop and the rest of the dependencies of gnome-desktop-sharp was recently updated to 2.26.0, while gnome-desktop-sharp is still at 2.24 and hasn't been rebuilt since F10. 

I've done a scratch rebuild of gnome-desktop-sharp, updating it to 2.26.0 and building against the updated rawhide gnome stack which is available here: http://koji.fedoraproject.org/koji/taskinfo?taskID=1277450

Please try and update to gnome-desktop-sharp 2.26.0 as provided above and see if this fixes the problem. Remember to restart gnome-do.
Comment 5 Chris Bagwell 2009-04-04 18:50:40 EDT
I can confirm the gnome-desktop-sharp 2.26.0 RPM from koji stops the gnome-do crash.   Plugins seem to not be working but the crash itself is fixed.

I haven't been able to track down plugin issues yet so it could be unique to my box.
Comment 6 Sindre Pedersen Bjørdal 2009-04-04 19:29:48 EDT

*** This bug has been marked as a duplicate of bug 494132 ***
Comment 7 adriano 2009-04-08 07:18:20 EDT
(In reply to comment #6)
> 
> *** This bug has been marked as a duplicate of 494132 ***  

(In reply to comment #5)
> I can confirm the gnome-desktop-sharp 2.26.0 RPM from koji stops the gnome-do
> crash.   Plugins seem to not be working but the crash itself is fixed.
> 
> I haven't been able to track down plugin issues yet so it could be unique to my
> box.  

gnome-desktop-sharp 2.26 seems has fixed the problem. But now gnome-do crashes 
because it cannot find '/usr/share/applications/gnome-do.desktop' when I'm triyng to open gnome-do Preferences.

here the console output

[ciao@localhost ~]$ gnome-do
Marshaling activate signal
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> GLib.GException: Error stating file '/usr/share/applications/gnome-do.desktop': No such file or directory
  at Gnome.DesktopItem.NewFromFile (System.String file, DesktopItemLoadFlags flags) [0x00000] 
  at Do.Platform.Linux.SystemService.get_AutoStartFile () [0x00000] 
  at Do.Platform.Linux.SystemService.IsAutoStartEnabled () [0x00000] 
  at Do.UI.GeneralPreferencesWidget.get_AutostartEnabled () [0x00000] 
  at Do.UI.GeneralPreferencesWidget..ctor () [0x00000] 
  at Do.UI.PreferencesWindow..ctor () [0x00000] 
  at Do.Core.Controller.ShowPreferences () [0x00000] 
  at Do.Universe.PreferencesItem.Run () [0x00000] 
  at Do.UI.MainMenu+<MenuItemFromRunnableItem>c__AnonStorey12.<>m__20 (System.Object sender, System.EventArgs e) [0x00000] 
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] 
  --- End of inner exception stack trace ---
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] 
  at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] 
  at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x00000] 
  at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00000] 
  at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000] 
  at GLib.Signal.ClosureInvokedCB (System.Object o, GLib.ClosureInvokedArgs args) [0x00000] 
  at GLib.SignalClosure.Invoke (GLib.ClosureInvokedArgs args) [0x00000] 
  at GLib.SignalClosure.MarshalCallback (IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data) [0x00000] 
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at GLib.SignalClosure.MarshalCallback(IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Do.Do.Main(System.String[] args)
[ciao@localhost ~]$
Comment 8 Sindre Pedersen Bjørdal 2009-04-10 14:49:21 EDT
*** Bug 494728 has been marked as a duplicate of this bug. ***
Comment 9 Sindre Pedersen Bjørdal 2009-04-10 14:49:35 EDT
*** Bug 495106 has been marked as a duplicate of this bug. ***
Comment 10 Sindre Pedersen Bjørdal 2009-04-10 14:49:42 EDT
*** Bug 494235 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.