Bug 493440 - mpirun is MIA on openmpi rpms, again...
mpirun is MIA on openmpi rpms, again...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: releng (Show other bugs)
4.8
All Linux
high Severity high
: rc
: ---
Assigned To: Doug Ledford
Red Hat Kernel QE team
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 14:58 EDT by Gurhan Ozen
Modified: 2013-11-03 20:42 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 495893 (view as bug list)
Environment:
Last Closed: 2009-05-19 09:40:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gurhan Ozen 2009-04-01 14:58:09 EDT
Description of problem: 

This seems to be a repeat of #443795:

[root@dell-pe1950-02 ~]# mpi-selector --query 
default:openmpi-1.2.8-gcc-i386
level:system
[root@dell-pe1950-02 ~]# which mpirun 
/usr/bin/which: no mpirun in (/usr/lib/openmpi/1.2.8-gcc/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin)
[root@dell-pe1950-02 ~]# which mpicc
/usr/lib/openmpi/1.2.8-gcc/bin/mpicc


Version-Release number of selected component (if applicable):
openmpi-libs-1.2.8-3.el4

How reproducible:
Very.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 4 Gurhan Ozen 2009-04-02 13:26:56 EDT

*** This bug has been marked as a duplicate of bug 443795 ***
Comment 5 Doug Ledford 2009-04-03 12:53:33 EDT
This is not a dup of 443795.  The mpirun binary is part of the openmpi package, not openmpi-libs.  The chain of dependencies is:

openmpi-devel requires openmpi requires openmpi-libs.  If you install openmpi-libs by itself, that's perfectly valid and it does not contain an mpirun binary.  Please verify that you have the openmpi package installed in addition to openmpi-libs.
Comment 10 Mike Bonnet 2009-04-15 11:02:23 EDT
Also updated comps to mark openmpi as multilib.
Comment 13 Gurhan Ozen 2009-04-15 13:55:50 EDT
(In reply to comment #10)
> Also updated comps to mark openmpi as multilib.  

Thanks,i'll pull the packages off and see how it behaves now.

Note You need to log in before you can comment on or make changes to this bug.