Bug 493467 - PATA / ata_piix 80-wire cable not correctly detected
PATA / ata_piix 80-wire cable not correctly detected
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 16:24 EDT by Markus B.
Modified: 2010-02-13 16:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-13 16:43:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (34.45 KB, text/plain)
2009-04-01 16:26 EDT, Markus B.
no flags Details
dmidecode (8.07 KB, text/plain)
2009-04-01 16:26 EDT, Markus B.
no flags Details
lspci -vv (16.52 KB, text/plain)
2009-04-01 16:27 EDT, Markus B.
no flags Details
dsdt (179.28 KB, text/plain)
2009-04-01 16:27 EDT, Markus B.
no flags Details
inteltool -a (180.64 KB, text/plain)
2009-04-01 16:27 EDT, Markus B.
no flags Details

  None (edit)
Description Markus B. 2009-04-01 16:24:56 EDT
Description of problem:
-----------------------
The kernel detects the controller and the drive correctly as UDMA/100 capable, but it limits the connection to UDMA/33 because it detects a 40-wire cable instead of a 80-wire cable.

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
Linux noname 2.6.29-0.258.2.3.rc8.git2.fc11.i586 #1 SMP Tue Mar 24 18:37:23 EDT 2009 i686 i686 i386 GNU/Linux

Actual results:
---------------
From dmesg:

scsi5 : ata_piix
ata5: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0xfa00 irq 14
ata6: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xfa08 irq 15
ata5.00: ATA-5: ST320011A, 3.75, max UDMA/100
ata5.00: 39102336 sectors, multi 1: LBA 
ata5.00: limited to UDMA/33 due to 40-wire cable
ata5.00: configured for UDMA/33

Expected results:
-----------------
ata5.00: configured for UDMA/100

Additional info:
----------------
* The cable is definitely a 80-wire cable. I've tried two different 80-wire cables, but both get detected as 40-wire cable.
* I have the same problem on Fedora 10, so this is not a rawhide regression.
Comment 1 Markus B. 2009-04-01 16:26:11 EDT
Created attachment 337651 [details]
dmesg
Comment 2 Markus B. 2009-04-01 16:26:40 EDT
Created attachment 337653 [details]
dmidecode
Comment 3 Markus B. 2009-04-01 16:27:09 EDT
Created attachment 337654 [details]
lspci -vv
Comment 4 Markus B. 2009-04-01 16:27:32 EDT
Created attachment 337655 [details]
dsdt
Comment 5 Markus B. 2009-04-01 16:27:57 EDT
Created attachment 337657 [details]
inteltool -a
Comment 6 Markus B. 2009-04-09 09:18:26 EDT
Adding "libata.force=5.00:80c" to the kernel boot parameters works as a workaround.
Comment 7 Bug Zapper 2009-06-09 09:01:04 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Markus B. 2010-02-13 16:43:03 EST
The problem is gone in Fedora 12.

Note You need to log in before you can comment on or make changes to this bug.