Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 493537 - exception when switching CDs
exception when switching CDs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:529db17f95d4ca35a...
:
: 493579 494211 495063 496420 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 03:32 EDT by Ben Lambrechts
Modified: 2009-04-20 10:42 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-02 13:15:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (166.41 KB, text/plain)
2009-04-02 03:32 EDT, Ben Lambrechts
no flags Details
Attached traceback automatically from anaconda. (188.21 KB, text/plain)
2009-04-05 23:54 EDT, cpg
no flags Details

  None (edit)
Description Ben Lambrechts 2009-04-02 03:32:25 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/image.py", line 290, in unmountCD
    % (dev.path,))
  File "/usr/lib/anaconda/yuminstall.py", line 694, in mirrorFailureCB
    unmountCD(self.tree, self.anaconda.intf.messageWindow)
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 301, in _failure
    action = cb(cb_obj, *args, **kwargs) or {}
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 406, in _mirror_try
    self._failure(gr, obj)
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 412, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 781, in _getFile
    http_headers=headers,
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 935, in _getFileRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1154, in _commonLoadRepoXML
    result = self._getFileRepoXML(local, text)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1308, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1324, in _loadRepoXML
    return self._groupLoadRepoXML(text, ["primary"])
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1334, in _getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1342, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1179, in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 220, in _check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 162, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 259, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 488, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 464, in doSackSetup
    return self._getSacks(archlist=archlist, thisrepo=thisrepo)
  File "/usr/lib/anaconda/yuminstall.py", line 1076, in <lambda>
    self.__withFuncDo(anaconda, lambda r: self.ayum.doSackSetup(thisrepo=r.id),
  File "/usr/lib/anaconda/yuminstall.py", line 1103, in __withFuncDo
    fn(repo)
  File "/usr/lib/anaconda/yuminstall.py", line 1077, in doSackSetup
    thisrepo=thisrepo, fatalerrors=fatalerrors)
  File "/usr/lib/anaconda/iw/task_gui.py", line 45, in setupRepo
    anaconda.backend.doSackSetup(anaconda, thisrepo=repo.id, fatalerrors=False)
  File "/usr/lib/anaconda/iw/task_gui.py", line 361, in run
    if not setupRepo(self.anaconda, self.repo):
  File "/usr/lib/anaconda/iw/task_gui.py", line 503, in _addRepo
    if dialog.run() == gtk.RESPONSE_CANCEL:
AttributeError: 'str' object has no attribute 'path'
Comment 1 Ben Lambrechts 2009-04-02 03:32:35 EDT
Created attachment 337730 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-04-02 10:08:23 EDT
*** Bug 493579 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2009-04-02 13:15:54 EDT
This should be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 4 cpg 2009-04-05 23:54:52 EDT
Created attachment 338283 [details]
Attached traceback automatically from anaconda.
Comment 5 Chris Lumens 2009-04-06 10:16:51 EDT
*** Bug 494211 has been marked as a duplicate of this bug. ***
Comment 6 Chris Lumens 2009-04-09 10:32:39 EDT
*** Bug 495063 has been marked as a duplicate of this bug. ***
Comment 7 Chris Lumens 2009-04-20 10:42:15 EDT
*** Bug 496420 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.