Bug 493581 - loaded hanged without NOSMP and NOAPIC in grub.conf
loaded hanged without NOSMP and NOAPIC in grub.conf
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Prarit Bhargava
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 07:01 EDT by Szymon Gruszczynski
Modified: 2011-10-17 10:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-17 10:21:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
thats my computers lspci -vv (21.87 KB, text/plain)
2009-04-02 07:03 EDT, Szymon Gruszczynski
no flags Details
thats lsmod of my computer (3.04 KB, text/plain)
2009-04-02 07:04 EDT, Szymon Gruszczynski
no flags Details
this is sosreport -avv from my computer (2.07 MB, application/x-bzip2)
2009-04-18 14:15 EDT, Szymon Gruszczynski
no flags Details
dmesg - 2.6.18-139 - noapic nosmp debug (23.59 KB, application/octet-stream)
2009-04-20 05:59 EDT, Szymon Gruszczynski
no flags Details
dmesg - 2.6.18-139.el5debug - noapic nosmp debug (23.95 KB, application/octet-stream)
2009-04-20 06:01 EDT, Szymon Gruszczynski
no flags Details

  None (edit)
Description Szymon Gruszczynski 2009-04-02 07:01:46 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.6) Gecko/2009020414 CentOS/3.0.6-1.el5.centos Firefox/3.0.6

hi
when i try to boot CentOS5.3 (yes, i know, its not RHEL, but its based on it) on default kernel ( 2.6.18-128.el5 ) on motherboard EP45-UD3 (gigabyte) and cpu E8400, i get the system restarted- shortly before it, i get the following information:

SMP alternatives: switching to SMP
booting processor 1/2 Apic 0x1

(than i get some text- but it goes to fast to be readed)
adding NOSMP and NOAPIC options to grub 'solve' this problem (well... system works, but see only 1 core in /proc/cpuinfo )


Reproducible: Always

Steps to Reproduce:
1.press the 'power' button
2.wait few seconds to see POST
3.select kernel in grub
Comment 1 Szymon Gruszczynski 2009-04-02 07:03:53 EDT
Created attachment 337775 [details]
thats my computers lspci -vv
Comment 2 Szymon Gruszczynski 2009-04-02 07:04:31 EDT
Created attachment 337777 [details]
thats lsmod of my computer
Comment 3 Anton Arapov 2009-04-02 07:34:42 EDT
CentOS is based on EL sources, but the kernels are different. Different configs are used, we can't obviously vouch for anything EL unrelated.

anyway, please try to reproduce the issue with the kernel from this place:
http://people.redhat.com/dzickus/el5/137.el5/
Comment 4 Szymon Gruszczynski 2009-04-05 11:55:31 EDT
i'm afraid, i am able to reproduce this bug in kernel 137.el5.
on default options (noapic rhgb (?) quiet) system hangs same as on noapic quiet or noapic rhgd (?), it works only on noapic nosmp. System randomly works with noapic option only (than i'm happy becouse i get both my cores working :/)
Comment 5 Prarit Bhargava 2009-04-15 10:40:36 EDT
Szymon, could you run 'sosreport' on your system and attach it to this BZ?  I'd like to see if I have a similar system within RH so I can replicate your problem.

Thanks,

P.
Comment 6 Szymon Gruszczynski 2009-04-18 14:15:39 EDT
Created attachment 340169 [details]
this is sosreport -avv from my computer

hi.
i'm sorry that my answer was so late, i coulnt send it earlier (sorry).
i've runned it on 2.6.18-139.el5 kernel, which is the newest at the moment; its downloaded from link that was given to me in previous post. the system was freshly installed (well... i also installed few gui programs, but they shouldnt matter afaik).
Comment 7 Prarit Bhargava 2009-04-19 18:11:20 EDT
Okay, I'm looking for a similar system internally.  In the meantime, could remove "rhgb quiet" from the boot options in /boot/grub/menu.lst, and replace them with "debug"?

That will give you a lot of useful output -- hopefully you can capture that and we can get an idea of what is going wrong.

Thanks,

P.
Comment 8 Szymon Gruszczynski 2009-04-20 05:59:56 EDT
Created attachment 340310 [details]
dmesg - 2.6.18-139 - noapic nosmp debug

this is a dmesg from my 2.6.18-139el5 kernel with nosmp noapic debug options.
Without 'nosmp noapic' options system, as i wrote earlier, doesn't boot. unfortunately text goes to fast to be readed (although, it stops for a second with the same info, given in first post). unfortunatelly, i dont know how to save them, so i not really can post them here.
in a second attachment i'll attach a dmesg from 2.6.18-139debug kernel (downloaded and installed) with noapic nosmp debug boot-options.
Comment 9 Szymon Gruszczynski 2009-04-20 06:01:16 EDT
Created attachment 340311 [details]
dmesg - 2.6.18-139.el5debug - noapic nosmp debug

this is a dmesg from kernel 2.6.18-139.el5debug. i hope it will help a bit :~
Comment 10 Prarit Bhargava 2009-04-20 07:30:24 EDT
Hi Szymon, 

Looks like you have a new Intel Wolfdale processor -- I've asked internally if we have one of those.  It's interesting that only UP boot works here...

P.
Comment 11 Szymon Gruszczynski 2009-04-20 17:16:38 EDT
forgive me asking - what "UP" stands for?
anyway- if you would like to get more information, just write it (and, if possible, write how could i obtain them, i.e. what commands etc etc).

sincerely
szymon
Comment 12 Prarit Bhargava 2009-04-21 08:34:39 EDT
(In reply to comment #11)
> forgive me asking - what "UP" stands for?

UP = Uniprocessor, ie) one processor
SMP = Symmetric Multi-Processor, ie) many processors


> anyway- if you would like to get more information, just write it (and, if
> possible, write how could i obtain them, i.e. what commands etc etc).

Just curious, does your system boot if you do "maxcpus=1" instead of nosmp ?

P.
Comment 13 Szymon Gruszczynski 2009-04-21 17:21:43 EDT
thanx for informing what UP means- i had no clue about it :~.
and about maxcpus=1 - system boots with it, it can be the only option in grub (i.e. i dont have to use 'noapic' option)- but without this 'noapic' it still a bit non-responsible (i.e. it behaves like i'd try to run it on machine with 32mb ram and pantium 166mhz with MMX- menu is slowly, system freezes sometimes - even KDE's clock stops for few seconds /up to 15/ - and yes, i checked, both processor and memory are mostly unused /they are used in about 10-30%/)

szymon
Comment 14 Prarit Bhargava 2011-10-17 10:21:18 EDT
Unlikely to be fixed in RHEL5.  Closing as WONTFIX.

P.

Note You need to log in before you can comment on or make changes to this bug.