Bug 493592 - The httpd package shouldn't obsolete mod_jk
The httpd package shouldn't obsolete mod_jk
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: httpd (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Joe Orton
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 08:20 EDT by Matthias Saou
Modified: 2009-09-02 07:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:51:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2009-04-02 08:20:48 EDT
I've deployed mod_jk on some production RHEL5 servers, and the problem is that every time an updated httpd package gets installed, mod_jk gets removed. This is because the httpd has an unversioned "obsoletes" on mod_jk.

I checked in Fedora, and that obsoletes was removed from the httpd package back in 2007. But the RHEL package still has it. I don't know or understand the reason behind that obsoletes, as none is given in the %changelog for the addition nor the removal. But I don't think removing it from the RHEL package could break anything, it could only avoid breakage. This is why I'm asking to have it removed.

At the very least, if this is for some (old) upgrade path, then version the obsoletes with the lowest possible mod_jk version to at least not cause problems with setups where mod_jk is recent.
Comment 1 Joe Orton 2009-04-02 08:41:58 EDT
Hmmmm.  That change was introduced:

* Mon Dec  5 2005 Joe Orton <jorton@redhat.com> 2.2.0-2

I think we expected at the time that mod_jk would indeed be obsoleted by mod_proxy_ajp.  But I agree that the Obsoletes is inappropriate.  Thanks for the report.
Comment 2 Matthias Saou 2009-04-02 10:25:13 EDT
FWIW, I've just checked and the EL4 httpd package is fine.

It's strange that no one has reported it before against EL5, as it has apparently already been noticed by others, for instance in bug #440159.
Comment 7 errata-xmlrpc 2009-09-02 07:51:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1380.html

Note You need to log in before you can comment on or make changes to this bug.