Bug 493624 - Monitor distortions after display rotation with Radeon rs482 (1002:5975)
Monitor distortions after display rotation with Radeon rs482 (1002:5975)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 08:46 EDT by Joshua Covington
Modified: 2009-04-16 17:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 17:50:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (56.19 KB, text/plain)
2009-04-03 19:13 EDT, Joshua Covington
no flags Details
Xorg.0.log after rotation (107.32 KB, text/plain)
2009-04-03 20:00 EDT, Joshua Covington
no flags Details
xorg.0.log-6.12.2-4 (63.16 KB, text/plain)
2009-04-16 16:34 EDT, Joshua Covington
no flags Details

  None (edit)
Description Joshua Covington 2009-04-02 08:46:48 EDT
Description of problem:
After step 4 in https://fedoraproject.org/wiki/QA:Testcase_radeon_rotate I get dispaly distortions. The mouse pointer rotates properly but I cannot recognize anything else.


Version-Release number of selected component (if applicable):
test live cd http://jlaska.fedorapeople.org/live/livecd-fedora-livecd-testday-20090331-x86_64.iso

Additional info:
smolt profile: http://www.smolts.org/client/show/pub_1ea45a8d-e70f-424f-aeab-c04eaec10b6f
Comment 1 Matěj Cepl 2009-04-03 11:58:50 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Joshua Covington 2009-04-03 19:13:29 EDT
Created attachment 338132 [details]
Xorg.0.log

I'm using the livecd and there is no xorg.conf file. I cannot attach the xorg.0.log after rotating the screen because I can't see/do anything and the only way is to restart the computer (livecd).
Comment 3 Joshua Covington 2009-04-03 20:00:57 EDT
Created attachment 338134 [details]
Xorg.0.log after rotation

I used crond to copy the log file after applying the rotation. I hope it can help.
Comment 4 Dave Airlie 2009-04-14 23:10:57 EDT
does this still happen with latest kernel + xorg-x11-drv-ati-6.12.2-2?
Comment 5 Joshua Covington 2009-04-16 16:34:55 EDT
Created attachment 339919 [details]
xorg.0.log-6.12.2-4

This is the xorg.0.log with ati-6.12.2-4 and kde4.2.2 after rotation. I tested this with kde-livecd and the rotation works in all directions. There are small problems with the cursor (it changes its shape and direction after going out and back in the visible display area) but it is drawn correctly.

This bug report was filed after testing with the gnome-livecd but I don't think this should be a problem. The bug is now fixed, though.
Comment 6 François Cami 2009-04-16 17:50:08 EDT
Thanks for testing, Joshua.
Closing.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.