Bug 493633 - devkit-disks-daemon avc denials after login
devkit-disks-daemon avc denials after login
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: DeviceKit-disks (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
: SELinux
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 09:19 EDT by Tomáš Bžatek
Modified: 2015-03-03 17:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 12:58:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomáš Bžatek 2009-04-02 09:19:25 EDT
Description of problem:
found some AVC denials in dmesg

Version-Release number of selected component (if applicable):
  selinux-policy-3.6.10-5.fc11.noarch
  DeviceKit-disks-003-9.fc11.x86_64
  DeviceKit-003-1.x86_64

How reproducible:
always

Steps to Reproduce:
1. Just login to default Gnome session, let nautilus run on the desktop
  
Actual results:


type=1400 audit(1238677349.260:12): avc:  denied  { getattr } for  pid=4264 comm="devkit-disks-da" path="/data" dev=sda7 ino=2 scontext=system_u:system_r:devicekit_disk_t:s0-s0:c0.c1023 tcontext=system_u:object_r:nfs_t:s0 tclass=dir
	Was caused by:
		Missing type enforcement (TE) allow rule.

		You can use audit2allow to generate a loadable module to allow this access.

type=1400 audit(1238677349.260:13): avc:  denied  { search } for  pid=4264 comm="devkit-disks-da" name="/" dev=sda7 ino=2 scontext=system_u:system_r:devicekit_disk_t:s0-s0:c0.c1023 tcontext=system_u:object_r:nfs_t:s0 tclass=dir
	Was caused by:
		Missing type enforcement (TE) allow rule.

		You can use audit2allow to generate a loadable module to allow this access.


Couldn't get nicer output because 
$ sealert --help
Segmentation fault
Comment 1 David Zeuthen 2009-04-07 12:58:42 EDT
The SELinux policy for DeviceKit-disks is not part of DeviceKit-disks itself so it is impossible for me or other maintainers to fix it. You should file this against SELinux (or reopen and reassign).

Note You need to log in before you can comment on or make changes to this bug.