Bug 493636 - Unable to use --cc option
Unable to use --cc option
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: python-bugzilla (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 09:23 EDT by Roman Rakus
Modified: 2014-01-12 19:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-05 01:57:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Rakus 2009-04-02 09:23:16 EDT
Description of problem:
When trying to use --cc option bugzilla traceback.

Version-Release number of selected component (if applicable):
3.2.2

How reproducible:
always

Steps to Reproduce:
1. some bugzilla cmd with --cc 'rrakus@redhat.com'
2.
3.
  
Actual results:
 Traceback (most recent call last):                                                                                       
   File "/usr/bin/bugzilla", line 521, in <module>                                                                        
     main()                                                                                                               
   File "/usr/bin/bugzilla", line 429, in main                                                                            
     b = bz.createbug(**data)                                                                                             
   File "/usr/lib/python2.5/site-packages/bugzilla/base.py", line 671, in createbug                                       
     bug_id = self._createbug(**data)                                                                                     
   File "/usr/lib/python2.5/site-packages/bugzilla/bugzilla3.py", line 82, in _createbug                                  
     r = self._proxy.Bug.create(data)                                                                                     
   File "/usr/lib64/python2.5/xmlrpclib.py", line 1150, in __call__                                                       
     return self.__send(self.__name, args)                                                                                
   File "/usr/lib64/python2.5/xmlrpclib.py", line 1440, in __request                                                      
     verbose=self.__verbose                                                                                               
   File "/usr/lib/python2.5/site-packages/bugzilla/base.py", line 776, in request                                         
     return self._parse_response(h.getfile(), sock)                                                                       
   File "/usr/lib64/python2.5/xmlrpclib.py", line 1343, in _parse_response                                                
     return u.close()                                                                                                     
   File "/usr/lib64/python2.5/xmlrpclib.py", line 790, in close                                                           
     raise Fault(**self._stack[0])                                                                                        
 xmlrpclib.Fault: <Fault -32000: 'Can\'t use string ("rrakus@redhat.com") as an ARRAY ref while "strict refs" in use at Bugzilla/Bug.pm line 1282.\n'>
                                                   

Expected results:
Added bug

Additional info:
Works well with F-8's bugzilla
Comment 1 Emmanuel Seyman 2009-04-08 04:57:44 EDT
This looks like a bug in python-bugzilla more than bugzilla proper.
Changing accordingly.
Comment 2 Will Woods 2009-04-08 10:51:49 EDT
What version of python-bugzilla are you using? Can you try again using python-bugzilla-0.5 from rawhide?
Comment 3 Jaroslav Reznik 2009-04-09 06:27:42 EDT
Hi,
I've tried python-bugzilla-0.5 but from Koji for F10 (as rawhide version needs python(abi) 2.6) and it's not working - same error message.

rpm -q python-bugzilla
python-bugzilla-0.5-1.fc10.noarch
Comment 4 Will Woods 2009-04-09 12:15:21 EDT
Weird. The command: 
  bugzilla query --cc 'rrakus@redhat.com'
works for me with python-bugzilla-0.5-1.fc11, using bugzilla.redhat.com. Are you testing against a different bugzilla instance?
Comment 5 Roman Rakus 2009-04-10 04:03:30 EDT
Yeah... query works, but new doesn't
Comment 6 Bug Zapper 2009-06-09 09:05:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Ivana Varekova 2009-10-13 08:07:24 EDT
Hello,
I just reproduce the bug on fc10, fc12 (python-bugzilla-0.5.1), so I'm changing version to 12. 
There is also patch:
https://fedorahosted.org/python-bugzilla/ticket/21
which looks like it fixes this bug.
Comment 8 Bug Zapper 2009-11-16 04:54:17 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2010-11-04 07:23:27 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2010-12-05 01:57:48 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.