Bug 493644 - Anaconda crashes at end of installation
Anaconda crashes at end of installation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
anaconda_trace_hash:491f6f474dce14412...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 09:39 EDT by Dimi Paun
Modified: 2009-04-16 15:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 15:10:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (217.00 KB, text/plain)
2009-04-02 09:40 EDT, Dimi Paun
no flags Details
Attached traceback automatically from anaconda. (208.60 KB, text/plain)
2009-04-10 02:00 EDT, A. Brown
no flags Details
Attached traceback automatically from anaconda. (155.70 KB, text/plain)
2009-04-10 07:11 EDT, A. Brown
no flags Details

  None (edit)
Description Dimi Paun 2009-04-02 09:39:58 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/booty/util.py", line 4, in getDiskPart
    path = storage.devicetree.getDeviceByName(dev).path[5:]
  File "/usr/lib/anaconda/booty/x86.py", line 374, in grubbyPartitionName
    (name, partNum) = getDiskPart(dev, self.storage)
  File "/usr/lib/anaconda/booty/x86.py", line 480, in upgradeGrub
    grubbyStage1Dev = self.grubbyPartitionName(stage1Dev)
  File "/usr/lib/anaconda/booty/x86.py", line 526, in write
    chainList, defaultDev, justConfig)
  File "/usr/lib/anaconda/bootloader.py", line 191, in writeBootloader
    justConfigFile)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1338, in handleRenderCallback
    self.currentWindow.renderCallback()
AttributeError: 'NoneType' object has no attribute 'path'
Comment 1 Dimi Paun 2009-04-02 09:40:05 EDT
Created attachment 337813 [details]
Attached traceback automatically from anaconda.
Comment 2 A. Brown 2009-04-10 02:00:51 EDT
Created attachment 339064 [details]
Attached traceback automatically from anaconda.
Comment 3 A. Brown 2009-04-10 02:05:51 EDT
Comment on attachment 339064 [details]
Attached traceback automatically from anaconda.

still updated the bootloader to the new kernel after upgrading from 9 to 11beta
Comment 4 A. Brown 2009-04-10 07:11:18 EDT
Created attachment 339081 [details]
Attached traceback automatically from anaconda.
Comment 5 Chris Lumens 2009-04-16 12:05:48 EDT
Can you please retest with rawhide?  There are a lot of changes to this area since the beta and it's likely we've resolved your problem.  Thanks.
Comment 6 Dimi Paun 2009-04-16 15:04:25 EDT
That's not something I can do easily, this is my production box (I know, I know :)), and now that I have it stable, I can't start all over again. Sorry.
Comment 7 Chris Lumens 2009-04-16 15:10:01 EDT
Oh, too bad.  I'm going to close as RAWHIDE for now.  If any of the other people CC'd on this bug can retest and reproduce the problem, please feel free to reopen it.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.