Bug 493675 - gnome-screensaver-gl-helper calls gdk_x11_visual_get_xvisual with NULL visual
gnome-screensaver-gl-helper calls gdk_x11_visual_get_xvisual with NULL visual
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 11:54 EDT by Tomislav Vujec
Modified: 2015-01-14 18:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-18 04:41:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to move xvisual retreival after the check for NULL visual. (868 bytes, patch)
2009-04-02 11:54 EDT, Tomislav Vujec
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 577739 None None None Never

  None (edit)
Description Tomislav Vujec 2009-04-02 11:54:05 EDT
Created attachment 337835 [details]
Patch to move xvisual retreival after the check for NULL visual.

Description of problem:
gnome-screensaver-gl-helper calls gdk_x11_visual_get_xvisual with NULL visual.
Thanks to gdk_x11_visual_get_xvisual asserting that visual is not NULL, only
error is reported and no harm is done. 
Use case for this is fairly hard to find, since most displays have xvisuals,
but it seems that after suspend event, gnome-screensaver calls gl-helper with
partially initialized display with no workable xvisuals.
Comment 1 Bug Zapper 2009-06-09 09:07:11 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Tomislav Vujec 2010-02-18 04:41:08 EST
Fixed in the upstream.

Note You need to log in before you can comment on or make changes to this bug.