This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 493678 - [RFE] Support Hyper-V fencing
[RFE] Support Hyper-V fencing
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fence-agents (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Marek Grac
GFS Bugs
: FutureFeature
: 614318 (view as bug list)
Depends On: 493677
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 12:00 EDT by Subhendu Ghosh
Modified: 2016-10-04 00:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 493677
Environment:
Last Closed: 2011-07-28 14:54:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Subhendu Ghosh 2009-04-02 12:00:42 EDT
This RFE needs to get updated to the correct (fence) component once the RHEL6 component list is updated.

+++ This bug was initially created as a clone of Bug #493677 +++

Support RHEL fencing of RHEL guests running on HyperV

Two different use cases exist:

1) fencing guests that are running on W2k8-HyperV Standard (without HA)
2) fencing guests that are running on w2k8-hyperV DataCenter of Enterprise (with HA)

http://www.microsoft.com/windowsserver2008/en/us/compare-features.aspx

This RFE is to support fencing the first use case - running on W2K8-HyperV Std.
Comment 1 RHEL Product and Program Management 2009-04-02 12:03:27 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Perry Myers 2010-07-14 11:16:27 EDT
*** Bug 614318 has been marked as a duplicate of this bug. ***
Comment 9 Sayan Saha 2010-09-09 16:46:29 EDT
This is 3rd in priority after VMware and RHEV. Looking like a RHEL 6.3 target at the moment. No clear customer demand seen yet.
Comment 10 Sayan Saha 2011-07-28 14:54:07 EDT
Closing this RFE for now. No current plans to support this because of lack of user interest and demand. Maybe re-opened later.
Comment 11 Michael Kushnir 2012-11-28 14:43:25 EST
We, at the National Library of Medicine at NIH would very much like to see this feature. 

We are a Red Hat Shop. We currently run clusters on vSphere, and we use the VMware fencing scripts. See our work at http://openi.nlm.nih.gov

As an educational institution, we get HyperV pracrically for free. The only thing preventing us from running Red Hat clusters on HyperV is the lack of a fencing agent. I would love to see a fencing agent for HyperV.

Just out of curiosity, what sort of demand study was done to support the statement "No clear customer demand seen yet?" 

Best,
Michael
Comment 12 Subhendu Ghosh 2012-11-28 16:06:04 EST
Hi Michael

Do you use Systems Center to manage the HyperV environment?
Is this based on Win 2008 or Win2012  configurations?

Also - since you already have RHEL and the embedded hypervisor - any plans to use that?

-regards
subhendu
Comment 13 Michael Kushnir 2012-11-28 16:20:24 EST
Hi Subhendu, 

Thanks for the quick response. 

We need enterprise grade virtualization with live migration and HA. So the product that meets our needs is RHEV. RHEV is price competitive with vSphere, but as I mentioned, we get HyperV for free (Windows Server Datacenter costs us about $4 per instance). So, future VM deployments will be HyperV only for the forseeable future. 

We have Microsoft System Center Virtual Machine Manager. Right now we use Win2008r2. We are looking forward to upgrading hypervisors to Win2012 when it becomes approved by NIH. 

At this point, my only solution for fencing off a HyperV based VM is to reboot the entire hypervisor server via IPMI. That is not really a good method. 

Thanks,
Michael
Comment 14 Marek Grac 2012-11-30 12:48:26 EST
@Michael:

It should be possible to use fence agents that uses libvirt (which have support for hyperV - at least in upstream) - you can use either fence_virsh, or fence_virt daemon.

Note You need to log in before you can comment on or make changes to this bug.