Bug 493688 - Confusing warning: "Unable to find watch for alarm XXXXX"
Confusing warning: "Unable to find watch for alarm XXXXX"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
: 481764 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 13:02 EDT by Tomislav Vujec
Modified: 2009-04-05 18:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-05 18:15:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch to disable no watch warning. (731 bytes, patch)
2009-04-02 13:02 EDT, Tomislav Vujec
no flags Details | Diff
Much improved patch proposal that disables useless warning only when it is really useless. (766 bytes, patch)
2009-04-02 22:59 EDT, Tomislav Vujec
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 577749 None None None Never

  None (edit)
Description Tomislav Vujec 2009-04-02 13:02:07 EDT
Created attachment 337850 [details]
Proposed patch to disable no watch warning.

Description of problem:
gnome-session seems to report the above warning at random times during desktop
session. This can be confusing to a user when noticed in either syslog or
console output.
The problem is that alarms that are being created to check on session's idle
state, are later destroyed when conditions for it are satisfied. However, when
an alarm is destroyed, xserver will send an event on it, and gnome-session will
try to locate the appropriate watch for that alarm which can't be located. Most
correct implementation would keep the watch structure and release it on receipt
of the final alarm event, but short of that, switching the message log level
from warning to debug removes the confusion.
Comment 1 Tomislav Vujec 2009-04-02 22:59:29 EDT
Created attachment 337970 [details]
Much improved patch proposal that disables useless warning only when it is really useless.

After spending some time on XSync protocol description, I realized that the
server does send an event with the state Destroyed after destroying an alarm.
This patch ignores such events. As long as alarms are only destroyed from watch
remove callback, this should work perfectly. However if that changes, the whole
event handler will need to change anyway.
Comment 2 Matthias Clasen 2009-04-05 18:14:29 EDT
*** Bug 481764 has been marked as a duplicate of this bug. ***
Comment 3 Matthias Clasen 2009-04-05 18:15:11 EDT
Thanks, I've committed this patch.

Note You need to log in before you can comment on or make changes to this bug.