Bug 493694 - UnicodeDecodeException during install
UnicodeDecodeException during install
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 13:31 EDT by Andrew McNabb
Modified: 2009-06-08 14:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-08 14:56:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew McNabb 2009-04-02 13:31:58 EDT
During the installation of Fedora 11 Beta, I got the following error messages in syslog.  It doesn't seem to be a particularly serious problem, but it's probably something that should be fixed.

Apr  1 09:42:57 prodigy ERROR   UnicodeDecodeException: line = <6>usb 5-1: Produ
ct: Natural<AE> Ergonomic Keyboard 4000
Apr  1 09:42:57 prodigy ERROR   UnicodeDecodeException: 'utf8' codec can't decod
e byte 0xae in position 28: unexpected code byte
Apr  1 09:42:57 prodigy WARNING /usr/lib/anaconda/gui.py:1024: GtkWarning: gtk_t
ext_buffer_emit_insert: assertion `g_utf8_validate (text, len, NULL)' failed#012
  textbuf.insert(iter, line)
Apr  1 09:42:57 prodigy ERROR   UnicodeDecodeException: line = <6>input: Microso
ft Natural<AE> Ergonomic Keyboard 4000 as /devices/pci0000:00/0000:00:1a.2/usb5/
5-1/5-1:1.0/input/input3
Apr  1 09:42:57 prodigy ERROR   UnicodeDecodeException: 'utf8' codec can't decod
e byte 0xae in position 27: unexpected code byte
Apr  1 09:42:57 prodigy ERROR   UnicodeDecodeException: line = <6>microsoft 0003
:045E:00DB.0001: input,hidraw0: USB HID v1.11 Keyboard [Microsoft Natural<AE> Er
gonomic Keyboard 4000] on usb-0000:00:1a.2-1/input0
Apr  1 09:42:57 prodigy ERROR   UnicodeDecodeException: 'utf8' codec can't decod
e byte 0xae in position 90: unexpected code byte
Apr  1 09:42:57 prodigy ERROR   UnicodeDecodeException: line = <6>input: Microso
ft Natural<AE> Ergonomic Keyboard 4000 as /devices/pci0000:00/0000:00:1a.2/usb5/
5-1/5-1:1.1/input/input4
Apr  1 09:42:57 prodigy ERROR   UnicodeDecodeException: 'utf8' codec can't decod
e byte 0xae in position 27: unexpected code byte
Apr  1 09:42:57 prodigy ERROR   UnicodeDecodeException: line = <6>microsoft 0003
:045E:00DB.0002: input,hidraw1: USB HID v1.11 Device [Microsoft Natural<AE> Ergo
nomic Keyboard 4000] on usb-0000:00:1a.2-1/input1
Apr  1 09:42:57 prodigy ERROR   UnicodeDecodeException: 'utf8' codec can't decod
e byte 0xae in position 88: unexpected code byte
Comment 1 Chris Lumens 2009-06-08 14:56:09 EDT
True it probably should be fixed since it looks bad, but I don't see how we're ever going to make this one high enough priority to ever fix it.  I believe the bug should be limited to people whose hardware information strings include something like (R) or (C), which shouldn't really be all that many people.

If you have a patch we'll be happy to take a look at it.

Note You need to log in before you can comment on or make changes to this bug.