Bug 493700 - Gedit insert spaces instead of tabs
Gedit insert spaces instead of tabs
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtksourceview (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 13:46 EDT by ritz
Modified: 2016-01-12 13:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-25 08:18:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch based on upstream code (994 bytes, patch)
2009-04-02 13:46 EDT, ritz
no flags Details | Diff

  None (edit)
Description ritz 2009-04-02 13:46:49 EDT
Created attachment 337861 [details]
patch based on upstream code

Please describe the problem:
I have checked the option "Insert spaces instead of tabs" in Gedit preferences,
but it doesn't work.

Steps to reproduce:
1. check option "Insert spaces instead of tabs" in Gedit preferences;
2. open a file (or create a new);
3. press <TAB>;

Actual results:
a tab was inserted instead spaces

Expected results:
"Insert spaces instead of tabs", of course

Does this happen every time?
Yes

Additional Information:
Upstream patch
http://git.gnome.org/cgit/preview/gtksourceview/commit/?id=1f44de0077a88e762b34c83ecbcfb7b378615f1f
Comment 3 Mike Leech 2010-02-26 10:39:48 EST
Having exactly the same problem. Is anybody going to fix it?
Comment 6 RHEL Product and Program Management 2010-08-09 15:24:59 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2011-05-31 10:50:12 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 9 RHEL Product and Program Management 2011-09-22 20:38:38 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 Tru Huynh 2016-01-12 13:58:02 EST
gedit-2.16.0-9.el5.x86_64:

gedit -> Edit -> preferences -> Editor tab

Tab width: 4
[X] insert spaces instead of tabs

1) if you have the keyboard [NUM Lock] key activated, gedit will insert <TAB> instead of 4 x <space> but 
2) if you remove the [NUM lock], and you get the 4 x <space> as expected.

ymmv, not calling for any action now, just fyi.

Note You need to log in before you can comment on or make changes to this bug.