Bug 49376 - wu-ftpd-2.6.0-14 logs with GMT when logged in as anonymous or ftp
wu-ftpd-2.6.0-14 logs with GMT when logged in as anonymous or ftp
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-18 15:37 EDT by Leonard den Ottolander
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-18 15:37:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonard den Ottolander 2001-07-18 15:37:12 EDT
Description of Problem:
 On systems with the system clock set to local time instead of GMT 
wu-ftpd-2.6.0-14.6x will log using GMT time when logged in as user ftp or 
anonymous. Regular users are logged with the (right) local time.
 I reproduced this behaviour on two different systems. Following are some 
log entries from the 2 systems (entries are in logged order):

Jul 18 09:35:36 rockingstone inetd[385]: pid 21993: exit status 1
Jul 18 07:36:10 rockingstone ftpd[21995]: ANONYMOUS FTP LOGIN FROM 
rockingstone.nl [212.204.221.111], 
Jul 18 07:36:32 rockingstone ftpd[21995]: FTP session closed
Jul 18 09:36:57 rockingstone ftpd[22081]: FTP LOGIN FROM 
c11024.upc-c.chello.nl [212.187.11.24], interstad
Jul 18 09:37:02 rockingstone ftpd[22081]: FTP session closed
Jul 18 10:05:03 rockingstone ftpd[22802]: FTP session closed
Jul 18 08:05:24 rockingstone ftpd[22847]: ANONYMOUS FTP LOGIN FROM 
rockingstone.nl [212.204.221.111], 
Jul 18 08:05:32 rockingstone ftpd[22847]: FTP session closed
Jul 18 10:05:34 rockingstone ftpd[22861]: FTP LOGIN FROM 
c11024.upc-c.chello.nl [212.187.11.24], interstad
Jul 18 10:05:37 rockingstone ftpd[22861]: FTP session closed

Jul 18 20:43:06 wc_rh62 ftpd[783]: FTP LOGIN FAILED (cannot set guest 
privileges) for wc_rh62.localdomain [192.168.0.77], ftp
Jul 18 20:43:10 wc_rh62 ftpd[783]: FTP session closed
Jul 18 18:44:22 wc_rh62 ftpd[791]: ANONYMOUS FTP LOGIN FROM 
wc_rh62.localdomain [192.168.0.77], 
Jul 18 18:44:35 wc_rh62 ftpd[791]: FTP session closed
Jul 18 20:45:06 wc_rh62 ftpd[794]: PAM-listfile: Refused user root for 
service ftp
Jul 18 20:45:07 wc_rh62 ftpd[794]: failed login from wc_rh62.localdomain 
[192.168.0.77]
Jul 18 20:45:11 wc_rh62 ftpd[794]: FTP session closed
Jul 18 20:45:17 wc_rh62 ftpd[796]: FTP LOGIN FROM wc_rh62.localdomain 
[192.168.0.77], leonard
Jul 18 20:45:30 wc_rh62 ftpd[796]: FTP session closed

 The respective /etc/sysconfig/clock files are:
ZONE="MET"
UTC=false
ARC=false

ZONE="Europe/Amsterdam"
UTC=false
ARC=false

How Reproducible:
 Run wu-ftpd-2.6.0-14.6x on a system with the system clock set to local 
time and notice the time shift in the logs when logging in as ftp or 
anonymous.

Actual Results:
 Log times in GMT.

Expected Results:
 Log times in local time.
Comment 1 Bernhard Rosenkraenzer 2001-07-19 05:44:56 EDT
That's because anonymous ftp does a chroot to /var/ftp, which doesn't contain 
an up-to-date /etc/localtime on your system.
Since there's no way we can check for changes in /etc/localtime while 
chrooted, the only way to fix it is doing it manually.

cp /etc/localtime /var/ftp/etc/localtime


Note You need to log in before you can comment on or make changes to this bug.