Bug 49377 - libpcap - broken include file nesting
libpcap - broken include file nesting
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: tcpdump (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-18 15:58 EDT by Daniel Roesen
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-19 07:16:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Roesen 2001-07-18 15:58:32 EDT
There are two problems with libpcap headers:

1) why did you move them to /usr/include/pcap? Many sources I compile must
   be manually patched because they expect them to be under /usr/include.

2) pcap/pcap.h includes net/bpf.h, which is actually now pcap/net/bpf.h,
   so including pcap.h

This problem is _very_ old. :-)
Comment 1 Pekka Savola 2001-07-19 07:16:43 EDT
because libpcap contains by default:

pcap.h
pcap-namedb.h
net/bpf.h

and net contains basically system-level stuff, I think the intent was to clearly
separate 
libpcap stuff from the rest.

It's IMO ok solution for this.

Patching can be minimized if 
 1) apps use autoconf :-), or
 2) just add -I/usr/include/pcap in CFLAGS ;-)

patching .h or .c files would be a real mess.. I tried that before starting to
use -I/usr/include/pcap.


Note You need to log in before you can comment on or make changes to this bug.