Bug 493775 - SB-Live 24 USB sound card is not available under output tab in "sound preferences"
SB-Live 24 USB sound card is not available under output tab in "sound prefere...
Status: CLOSED DUPLICATE of bug 489048
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 22:54 EDT by Mike Gahagan
Modified: 2009-04-10 10:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-10 10:44:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug pa log (76.73 KB, text/plain)
2009-04-05 18:54 EDT, Martin Ebourne
no flags Details

  None (edit)
Description Mike Gahagan 2009-04-02 22:54:57 EDT
Description of problem:
When plugging in an SB-Live 24 USB sound card, the device will show up under the input tab, it does not show up in the output tab. This makes the sound device unusable for output by the desktop. I was able to play sound sucessfully from the command line by specifying the digital output on the USB device manually.

Version-Release number of selected component (if applicable):
F11 Beta i386

How reproducible:
always

Steps to Reproduce:
1.connect USB sound card, it will show up as an input device but is unavailable as an output device.
2.
3.
  
Actual results:
sound doesn't work in the desktop/gui apps, no way to choose a usb device for output. 

Expected results:
sound works once USB device is selected for output. The same sound card works in F10 and RHEL 5

Additional info:
Comment 1 Lennart Poettering 2009-04-03 11:44:45 EDT
Did you hotplug the device?

If you use pavucontrol, can you activate the output from the 'Configuration' tab?

If you didn't hotplug the device you probably had some other app block access to the device. Set 'log-level' to 'debug' in /etc/pulse/daemon.conf and try to reproduce the issue. Thenplease paste PA's syslog output here.
Comment 2 Mike Gahagan 2009-04-03 12:56:53 EDT
I tried both hotplugging the device as well as connecting it prior to booting the system. I saw the same behavior in both cases. I'll try pavucontrol this weekend and let you know.
Comment 3 Mike Gahagan 2009-04-05 11:08:25 EDT
I tried running pavucontrol which I started from the command line because I couldn't find it in the menus. Pavucontrol seems to detect the USB device just fine. I tried both hotplugging the device several times as well booting the system with the USB device already connected. I selected the IEC958 output device on the SB live USB device from the configuration tab, then on the playback tab I could access the menu for the stream I wanted to play (the audacious music player in my case) and move it to the USB device. 

So, it looks like pavucontrol works fine even if it is not always obvious what I had to do to make it work like I wanted. Looks like we just need to fix up the gnome sound preferences app that comes up.
Comment 4 Martin Ebourne 2009-04-05 18:53:01 EDT
I'm having the same or similar problem with the SB-Live 24 USB. Mostly when I plug it in pulseaudio doesn't see it, sometimes it does though. When pa does see it input and output seems to work fine, including the volume applet.

On an unsuccessful plug I get these errors in the log:

Apr  5 23:43:17 avenin pulseaudio[3268]: module-alsa-card.c: Card '2' doesn't exist: Permission denied
Apr  5 23:43:17 avenin pulseaudio[3268]: module.c: Failed to load  module "module-alsa-card" (argument: "device_id=2 name=usb_device_41e_3040_noserial_if0_sound_card_0 card_name=alsa_card.usb_device_41e_3040_noserial_if0_sound_card_0 tsched=1"): initialization failed.
Apr  5 23:43:17 avenin pulseaudio[3268]: module-alsa-card.c: Card '2' doesn't exist: Permission denied
Apr  5 23:43:17 avenin pulseaudio[3268]: module.c: Failed to load  module "module-alsa-card" (argument: "device_id=2 name=usb_device_41e_3040_noserial_if0_sound_card_0 card_name=alsa_card.usb_device_41e_3040_noserial_if0_sound_card_0 tsched=1"): initialization failed.

aplay -D hw:2 always works.
Comment 5 Martin Ebourne 2009-04-05 18:54:33 EDT
Created attachment 338267 [details]
Debug pa log

Log from running pa in debug. Card was plugged in and recognised on restart, then I unplugged it and reinserted but not found the second time.
Comment 6 Lennart Poettering 2009-04-10 10:44:20 EDT

*** This bug has been marked as a duplicate of bug 489048 ***

Note You need to log in before you can comment on or make changes to this bug.