Bug 49380 - bind's status uses rncd; doesn't work
Summary: bind's status uses rncd; doesn't work
Status: CLOSED DUPLICATE of bug 48839
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bind   
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-18 20:08 UTC by Joshua Jensen
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-18 20:08:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joshua Jensen 2001-07-18 20:08:46 UTC
Bind's /etc/rc.d/init.d/named script uses, rndc for status.  The problem
is, rndc hasn't yet had it's status functionality implemented.  This causes
the non-descript status of:
rndc:  get key definition: not found

Solution:

Change the rhstatus() fuction in /etc/rc.d/init.d/named to be:

rhstatus() {
        /usr/sbin/rndc status
        status named
}

Or maybe:

rhstatus() {
/usr/sbin/rndc status 2> /dev/null || status named
}

IMO, either of these would be much better.

Thanks,

Joshua Jensen

Comment 1 Bernhard Rosenkraenzer 2001-07-19 09:39:09 UTC

*** This bug has been marked as a duplicate of 48839 ***


Note You need to log in before you can comment on or make changes to this bug.