Bug 493814 - spec file doesn't provide "provides" field
spec file doesn't provide "provides" field
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: smc-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 04:56 EDT by Pravin Satpute
Modified: 2009-04-03 05:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-03 05:35:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pravin Satpute 2009-04-03 04:56:38 EDT
Description of problem:
spec file doesn't provide "provides" field, other packages trying to installing with old name are failing due to this

Version-Release number of selected component (if applicable):
smc-meera-fonts-04.1-5

How reproducible:
every time


Steps to Reproduce:
1.try installing smc-fonts-meera it will say package does not exist 
2.
3.
  
Actual results:
it says 

Expected results:
it should still install smc-meera-fonts package

Additional info:
Comment 1 Pravin Satpute 2009-04-03 05:35:04 EDT
fixed in smc-fonts-04.1-6
i think it will be in tomorrow's rawhide
Comment 2 Nicolas Mailhot 2009-04-03 05:37:46 EDT
While you certainly have the option as maintainer to add Provides, you should note that other fedora font packages did not add them and the maintainers of packages depending on them just fixed their deps.

Which is the correct long-term fix anyway.
Comment 3 Pravin Satpute 2009-04-03 05:45:02 EDT
see https://bugzilla.redhat.com/show_bug.cgi?id=493792

I think we should keep it till f13 probably

Note You need to log in before you can comment on or make changes to this bug.