Bug 493932 - sky2 frees DMA memory with wrong function.
sky2 frees DMA memory with wrong function.
Status: CLOSED DUPLICATE of bug 493535
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 06:27 EDT by David Woodhouse
Modified: 2009-06-16 09:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-16 09:57:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2009-04-03 06:27:13 EDT
Apr  3 00:33:48 macbook kernel: sky2 0000:0c:00.0: DMA-API: device driver frees DMA memory with wrong function [device address=0x000000012fdc4000] [size=136 bytes] [mapped as page] [unmapped as single
]
Apr  3 00:33:48 macbook kernel: Modules linked in: nfs lockd nfs_acl auth_rpcgss tun rfcomm sco bridge stp llc bnep l2cap sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_o
ndemand acpi_cpufreq freq_table vfat fat dm_multipath kvm_intel kvm uinput arc4 ecb snd_hda_codec_realtek iwlagn snd_hda_intel snd_hda_codec iwlcore firewire_ohci uvcvideo applesmc snd_hwdep rfkill vi
deodev hwmon snd_pcm firewire_core lib80211 snd_timer v4l1_compat input_polldev joydev mac80211 mbp_nvidia_bl v4l2_compat_ioctl32 snd video btusb bcm5974 i2c_i801 pcspkr iTCO_wdt iTCO_vendor_support c
rc_itu_t usb_storage soundcore cfg80211 bluetooth sky2 output snd_page_alloc ata_generic pata_acpi nouveau drm i2c_core [last unloaded: microcode]
Apr  3 00:33:48 macbook kernel: Pid: 0, comm: swapper Not tainted 2.6.29.1-37.rc1.fc11.x86_64 #1
Apr  3 00:33:48 macbook kernel: Call Trace:
Apr  3 00:33:48 macbook kernel: <IRQ>  [<ffffffff8104d02f>] warn_slowpath+0xbc/0xf0
Apr  3 00:33:48 macbook kernel: [<ffffffff8106e544>] ? graph_unlock+0x6b/0x77
Apr  3 00:33:48 macbook kernel: [<ffffffff81071bc8>] ? __lock_acquire+0xb60/0xc06
Apr  3 00:33:48 macbook kernel: [<ffffffff811d4305>] ? get_hash_bucket+0x28/0x34
Apr  3 00:33:48 macbook kernel: [<ffffffff813c3958>] ? _spin_lock_irqsave+0x7d/0x8b
Apr  3 00:33:48 macbook kernel: [<ffffffff811d4305>] ? get_hash_bucket+0x28/0x34
Apr  3 00:33:48 macbook kernel: [<ffffffff811d2cad>] ? swiotlb_virt_to_bus+0x1f/0x23
Apr  3 00:33:48 macbook kernel: [<ffffffff811d4bb0>] check_unmap+0x2b4/0x3dd
Apr  3 00:33:48 macbook kernel: [<ffffffff810dbe99>] ? kmem_cache_free+0xd3/0xed
Apr  3 00:33:48 macbook kernel: [<ffffffff811d4e26>] debug_dma_unmap_page+0x50/0x52
Apr  3 00:33:48 macbook kernel: [<ffffffffa00c480c>] dma_unmap_single+0x6c/0x75 [sky2]
Apr  3 00:33:48 macbook kernel: [<ffffffffa00c484f>] pci_unmap_page+0x3a/0x57 [sky2]
Apr  3 00:33:48 macbook kernel: [<ffffffffa00c51b0>] sky2_tx_complete+0xb7/0x153 [sky2]
Apr  3 00:33:48 macbook kernel: [<ffffffff81327a3f>] ? netif_receive_skb+0x111/0x41a
Apr  3 00:33:48 macbook kernel: [<ffffffffa00c547c>] sky2_tx_done+0x2d/0x3a [sky2]
Apr  3 00:33:48 macbook kernel: [<ffffffffa00c7115>] sky2_poll+0x936/0xa70 [sky2]
Apr  3 00:33:48 macbook kernel: [<ffffffff813260bf>] net_rx_action+0xb6/0x1ee
Comment 1 Bug Zapper 2009-06-09 09:12:06 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Chuck Ebbert 2009-06-16 09:57:55 EDT

*** This bug has been marked as a duplicate of bug 493535 ***

Note You need to log in before you can comment on or make changes to this bug.