This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 493945 - SELinux is preventing setroubleshootd
SELinux is preventing setroubleshootd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
: SELinux
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 08:10 EDT by Marcela Mašláňová
Modified: 2009-04-03 09:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-03 09:58:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages selinux enforcing (220.22 KB, application/octet-stream)
2009-04-03 08:10 EDT, Marcela Mašláňová
no flags Details
messages selinux permissive (4.12 KB, application/octet-stream)
2009-04-03 08:12 EDT, Marcela Mašláňová
no flags Details
audit (29.45 KB, application/octet-stream)
2009-04-03 08:13 EDT, Marcela Mašláňová
no flags Details

  None (edit)
Description Marcela Mašláňová 2009-04-03 08:10:39 EDT
Created attachment 338027 [details]
messages selinux enforcing

Description of problem:
A lot of selinux messages in /var/log/messages

Version-Release number of selected component (if applicable):
selinux-policy-3.6.10-5.fc11.noarch
selinux-policy-targeted-3.6.10-5.fc11.noarch

How reproducible:
It looks like problem python2.6 and setroubleshooter.
  
Actual results:
Setroubleshooter can't run even in permissive mode. The whole system is after update and relabel. 

Expected results:
Working setroubleshooter without warnings. 

Additional info:
All logs attached.
Comment 1 Marcela Mašláňová 2009-04-03 08:12:25 EDT
Created attachment 338028 [details]
messages selinux permissive
Comment 2 Marcela Mašláňová 2009-04-03 08:13:30 EDT
Created attachment 338029 [details]
audit
Comment 3 Daniel Walsh 2009-04-03 09:58:04 EDT
The AVC messages about setroubleshoot are caused by a bug in the nss package, which should be fixed in todays rawhide.

The crashing of setroubleshoot is fixed by the update of todays libselinux.

setroubleshoot going nuts starting and stopping should be fixed by an update to its setroubleshoot package in tomorrows rawhide.

 nss                             x86_64 3.12.2.99.3-5.fc11      rawhide   1.0 M
 libselinux                      i586   2.0.79-5.fc11           rawhide   105 k

setroubleshoot-2.1.7-1.fc11

Note You need to log in before you can comment on or make changes to this bug.