Bug 493952 - Fedora11 Beta: missing "Prep" file system type partition editor
Fedora11 Beta: missing "Prep" file system type partition editor
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc64 All
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 09:00 EDT by IBM Bug Proxy
Modified: 2009-04-21 10:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 10:35:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda log (282.90 KB, text/plain)
2009-04-03 09:01 EDT, IBM Bug Proxy
no flags Details
Screenshot showing missing Prep file system type (139.10 KB, image/png)
2009-04-03 09:01 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description IBM Bug Proxy 2009-04-03 09:00:55 EDT
=Comment: #0=================================================
Pavan Naregundi <pavan.naregundi@in.ibm.com> - 

While trying to install f11beta on ppc machine, there was no option to select Prep file system type
in partition editor.

If we chose to continue with existing prep partition without formating, I got a anaconda exception
as shown below. 

===========
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/booty/ppc.py", line 19, in getBootDevs
    if dev.partedFlags[parted.PARTITION_PREP] and not dev.format.exists:
  File "/usr/lib/anaconda/booty/ppc.py", line 45, in writeYaboot
    yabootTarget = string.join(self.getBootDevs(bl))
  File "/usr/lib/anaconda/booty/ppc.py", line 171, in write
    chainList, defaultDev, justConfig)
  File "/usr/lib/anaconda/bootloader.py", line 191, in writeBootloader
    justConfigFile)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1338, in handleRenderCallback
    self.currentWindow.renderCallback()
AttributeError: 'LVMVolumeGroupDevice' object has no attribute 'partedFlags'
=============

Attaching the anaconda.log file..

Machine: P550
      
=================================================
Hello Red Hat,

we found 2 bugs that might be related to this issue:

https://bugzilla.redhat.com/show_bug.cgi?id=492426 - AttributeError: 'LVMVolumeGroupDevice' object
has no attribute 'partedFlags': shows the same traceback from the bug description. In according to
your bug report, it was already fixed upstream.

https://bugzilla.redhat.com/show_bug.cgi?id=492408 -  PPC PReP Boot partition not selectable from
partition type drop-down: this bug seems to address the main problem described here. It was not
fixed yet.

Please let us know if you need any additional information. 

Thanks for your support.
Comment 1 IBM Bug Proxy 2009-04-03 09:01:07 EDT
Created attachment 338034 [details]
anaconda log
Comment 2 IBM Bug Proxy 2009-04-03 09:01:16 EDT
Created attachment 338035 [details]
Screenshot showing missing Prep file system type
Comment 3 Chris Lumens 2009-04-03 10:20:14 EDT
Does using updates=http://clumens.fedorapeople.org/493952.img fix this?  You should probably test this against the latest rawhide - not the beta - for the best chances of not running into other issues.
Comment 4 IBM Bug Proxy 2009-04-21 06:21:08 EDT
------- Comment From pavan.naregundi@in.ibm.com 2009-04-21 06:16 EDT-------
(In reply to comment #9)
> Does using updates=http://clumens.fedorapeople.org/493952.img fix this?  You
> should probably test this against the latest rawhide - not the beta - for the
> best chances of not running into other issues.
>

Tried the update with beta got the exception as below, however now it shows the 'Prep' file system in partition editor. I will retest with rawhide shortly and update with by results.

===============================
anaconda 11.5.0.46 exception report
Traceback (most recent call first):
File "/tmp/updates/storage/__init__.py", line 788, in sanityCheck
self.anaconda.backend.rootFsType and
File "/usr/lib/anaconda/iw/partition_gui.py", line 610, in getNext
(errors, warnings) = self.storage.sanityCheck()
File "/usr/lib/anaconda/gui.py", line 1313, in nextClicked
rc = self.currentWindow.getNext ()
AttributeError: YumBackend instance has no attribute 'rootFsType'

Entering debugger...
> /tmp/updates/storage/__init__.py(788)sanityCheck()
-> self.anaconda.backend.rootFsType and
(Pdb) bt
/usr/bin/anaconda(1029)<module>()
-> anaconda.intf.run(anaconda)
/usr/lib/anaconda/gui.py(1270)run()
-> self.icw.run (self.runres)
/usr/lib/anaconda/gui.py(1524)run()
-> gtk.main()
/usr/lib/anaconda/gui.py(1315)nextClicked()
-> return
/usr/lib/anaconda/iw/partition_gui.py(610)getNext()
-> (errors, warnings) = self.storage.sanityCheck()
> /tmp/updates/storage/__init__.py(788)sanityCheck()
-> self.anaconda.backend.rootFsType and
(Pdb) l
783  	                          %(self.anaconda.backend.getMinimumSizeMB("/"),
784  	                            productName))help
785
786  	        # livecds have to have the rootfs type match up
787  	        if (root and
788  ->	            self.anaconda.backend.rootFsType and
789  	            root.format.type != self.anaconda.backend.rootFsType):
790  	            errors.append(_("Your / partition does not match the "
791  	                            "the live image you are installing from.  "
792  	                            "It must be formatted as %s.")
793  	                          % (self.anaconda.backend.rootFsType,))
(Pdb)
=========================

Thanks
Pavan
Comment 5 Chris Lumens 2009-04-21 10:35:09 EDT
Okay, this is because another file was missing out of the updates image that was unrelated to this bug, but was needed because something else got changed.  Thanks for testing the original problem.  I'm going to close this one out.

Note You need to log in before you can comment on or make changes to this bug.