Bug 493956 - unknown incompatibility between 0.10.9-3.el5 and 0.10.20-3.el5
unknown incompatibility between 0.10.9-3.el5 and 0.10.20-3.el5
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gstreamer (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Benjamin Otte
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 09:16 EDT by Dennis Gregorovic
Modified: 2014-12-15 21:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:36:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gregorovic 2009-04-03 09:16:28 EDT
pidgin 2.5.5-1.el5 was built against gstreamer 0.10.20-3.el5 and works fine with that version of gstreamer.  However, it doesn't work with the version of gstreamer in RHEL 5.2: 0.10.9-3.el5.  Yet, those two versions of gstreamer identify as being ABI-compatible:

$ rpm -q --provides -p `find_package gstreamer-0.10.9-3.el5.i386`
libgstbase-0.10.so.0
libgstcontroller-0.10.so.0
libgstcoreelements.so
libgstcoreindexers.so
libgstdataprotocol-0.10.so.0
libgstnet-0.10.so.0
libgstreamer-0.10.so.0
gstreamer = 0.10.9-3.el5

$ rpm -q --provides -p `find_package gstreamer-0.10.20-3.el5.i386`
libgstbase-0.10.so.0
libgstcontroller-0.10.so.0
libgstcoreelements.so
libgstcoreindexers.so
libgstdataprotocol-0.10.so.0
libgstnet-0.10.so.0
libgstreamer-0.10.so.0
gstreamer = 0.10.20-3.el5

$ rpm -qRp `find_package pidgin-2.5.5-1.el5.i386` | grep libgs
libgstreamer-0.10.so.0

I would expect that a package that Requires libgstreamer-0.10.so.0 would work with gstreamer-0.10.9-3.el5.i386.
Comment 1 RHEL Product and Program Management 2014-03-07 07:51:03 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-03 08:36:45 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.