Bug 493959 - Update MPT Fusion to version 4.00.13.10
Update MPT Fusion to version 4.00.13.10
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
All Linux
high Severity high
: beta
: 5.4
Assigned To: Tomas Henzl
Red Hat Kernel QE team
:
Depends On: 475455
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 09:34 EDT by Goutham Kandiar
Modified: 2014-11-09 17:45 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-03 11:56:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Goutham Kandiar 2009-04-03 09:34:52 EDT
A large customer, UBS, is requesting an update of the MPT Fusion driver in RHEL 5.4 to version 4.00.13.10.  The current version in RHEL 5.3 is 3.04.06.  LSI has requested through another BZ (475455) to update the driver to version 3.04.08.

This customer uses a significant amount of IBM hardware.  IBM supplies them with online firmware update scripts that can be used to flash the server's firmware.  In the case of the MPT Fusion devices, the IBM flash update has a requirement for driver version 4.00.13.10. 

UBS would like to use the Red Hat supplied driver for support and compliance purposes.  As a consequence, UBS is forced to use the offline update mechanism - an MS-DOS bootable flash - which is not acceptable.  Other hardware in the machine - BIOS, service processor, NIC firmware - can all be updated via online mechanisms.
Comment 1 Ian McLeod 2009-04-03 10:10:03 EDT
Just to be clear, the primary requirement is for a driver that supports the online firmware update utility.  At the moment, the firmware update tool reports that it requires a 4.x series driver for this to work.

If an update in the 3.x.x stream can accomplish this, that's fine.
Comment 2 Andrius Benokraitis 2009-04-03 10:49:03 EDT
I think re-basing is a kABI breaker.. Tom - can you verify?
Comment 3 Tomas Henzl 2009-04-03 10:51:57 EDT
(In reply to comment #1)
> Just to be clear, the primary requirement is for a driver that supports the
> online firmware update utility.  At the moment, the firmware update tool
> reports that it requires a 4.x series driver for this to work.
> 
> If an update in the 3.x.x stream can accomplish this, that's fine. 

I'm not aware of any 4.x version, maybe the problem is in the IBM tool.

Test kernel with our latest patch to 3.04.08rh can be found here ->
http://people.redhat.com/thenzl/mpt_fusion/

Sathya, Kashyap,
do you know what we need for this ?
Thanks,
Tomas
Comment 4 Andrius Benokraitis 2009-04-03 11:09:37 EDT
OK - I thought the 4.x version was the latest upstream version, I could be wrong.
Comment 5 Tom Coughlan 2009-04-03 11:51:11 EDT
No, upstream is MPT_LINUX_VERSION_COMMON        "3.04.07"
Comment 6 Andrius Benokraitis 2009-04-03 11:56:53 EDT
Ahhh, could be the out-of-box version then that LSI maintains themselves. This being the case, and it not being upstream, I don't see this happening unfortunately.
Comment 7 Goutham Kandiar 2009-04-03 12:15:53 EDT
Here is my understanding of the various versions:

RHEL 5.3   -  3.04.06
Kernel Upstream  -  3.04.07
Requested by LSI in BZ 475455  -  3.04.08
Requested by UBS for online firmware update  -  4.00.13.10
Latest from LSI (out-of-box)  -  4.16.00.00
Comment 8 Tom Coughlan 2009-04-03 13:57:34 EDT
(In reply to comment #0)

> the IBM flash update has a
> requirement for driver version 4.00.13.10. 

So the question for IBM or LSI Logic is whether the in-box driver version 3.04.06
or 3.04.08 can be supported with the online firmware update scripts. And if not, why not?
Comment 9 Sathya Prakash 2009-04-06 01:06:51 EDT
The 4.13.10.00 driver version is an older release of out-of-box driver.
The driver version 4.18.00.00 is the latest one. 
In general the utilities may work with the kernel upstream driver 3.04.08. But since all our testing is focused on the in-house (out-of-box) driver we can not assure whether the utilities WILL work fine with the upstream drivers without any hidden issues. So we always suggest to use the out-of-box driver with our utilities.

Regarding the script and it's compatibility with upstream drivers IBM has to comment, because I don't have any insight on what is the script doing and what application it uses internally to support our drivers.

Thanks
Sathya

Note You need to log in before you can comment on or make changes to this bug.