Bug 49399 - Cannot detect Netgear FA310TX card
Cannot detect Netgear FA310TX card
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: netcfg (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-18 21:01 EDT by Need Real Name
Modified: 2007-04-18 12:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-19 17:49:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-18 21:01:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
The install routine did not detect my network card (Netgear FA310TX).  
Everything else in the install worked successfully.  After installation, I 
tried to run netcfg to add a new Ethernet interface, but it still did not 
work.  This card is marked as compatible on the RedHat hardware 
compatibility list.  I know the card itself is good because I previously 
had Windows 95 installed on the machine and was able to use it with no 
problems.

How reproducible:
Always

Steps to Reproduce:
1.Run RedHat installation program
2.
3.
	

Actual Results:  The Network Configuration screen never appears...the 
install skips directly to the Firewall Configuration screen.

Expected Results:  I should have seen the Network Configuration screen 
with one device, eth0.  I should have been able to setup DHCP for this 
device.

Additional info:

I have the Linux box hooked to a Linksys router.  There is only one 
network card in the Linux box.
Comment 1 Tom Nelson 2001-07-18 21:43:32 EDT
I also had the same problem today (7/18/01) with a new installation.  My system
has two FA310TX cards and worked just fine under 6.1.  It appears that this
is not an isolated incident.
Comment 2 Need Real Name 2001-07-18 22:46:49 EDT
I got it to work...for some reason, the tulip driver that is needed by the 
Netgear card was not loaded.  Here is what I did:

1) login as root
2) run netcfg
3) add a new interface (type: Ethernet, activate at boot time, protocol: dhcp) 
4) save changes & quite netcfg
5) open the /etc/modules.conf file for editing
6) add the following line:  alias eth0 tulip
7) save the file
8) reboot the machine
Comment 3 Bill Nottingham 2001-07-18 23:00:58 EDT
lspci output?
Comment 4 Tom Nelson 2001-07-19 17:49:19 EDT
My cards are now working.  It seems the default installation program did not completely reformat the hard drive(s)
and remove all the legacy stuff from v6.  Once I manually reformatted the drive, the system initialized the cards
properly.  The key is modprobe doesn't find the modules dependency file because it's looking for the v6
file (which does not exist), not the v7.1 file (which does exist).
Comment 5 Bill Nottingham 2002-01-24 00:53:39 EST
Hm, odd. I haven't seen this here on upgrade tests; closing as worksforme.

Note You need to log in before you can comment on or make changes to this bug.