Bug 494054 - yum does not work correctly after installing FC11 Alpha
yum does not work correctly after installing FC11 Alpha
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
11
i386 Linux
low Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 17:16 EDT by Mariano Roig
Modified: 2014-01-21 18:08 EST (History)
7 users (show)

See Also:
Fixed In Version: 3.2.23-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 21:25:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mariano Roig 2009-04-03 17:16:28 EDT
Description of problem:


Version-Release number of selected component (if applicable):
yum-3.2.21-7.fc11
yum-metadata-parser-1.1.2-11.fc11


How reproducible:
Just run yum update, install or search.

Steps to Reproduce:
1. Install FC11 Alpha (10.91)
2. After install FC11 login as root
3. Run 'yum update'
  
Actual results:

# yum update 
Loaded plugins: dellsysidplugin2, refresh-packagekit
YumRepo Error: All mirror URLs are not using ftp, http[s] or file.
 Eg. </metalink>/
removing mirrorlist with no valid mirrors: //var/cache/yum/rawhide/mirrorlist.txt
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rawhide. Please verify its path and try again


Expected results:

The expected result is the update fedora.

Additional info:

This error also happens with install, search and any parameter.
Comment 1 James Antill 2009-04-04 00:44:26 EDT
> 1. Install FC11 Alpha (10.91)

 From what I can tell you have a newer fedora-release but an older yum. Do you know how this happened? Did you update the fedora-release after installing the Alpha?
 The beta was just released, you could install that directly. Or download the newer yum by hand (or comment out the baseurl by hand, from the fedora-rawhide.repo file).

 Jesse, can we just add a conflict on yum < 3.2.22-0 ?
Comment 2 Mariano Roig 2009-04-06 08:15:29 EDT
(In reply to comment #1)
> > 1. Install FC11 Alpha (10.91)
> 
>  From what I can tell you have a newer fedora-release but an older yum. Do you
> know how this happened? Did you update the fedora-release after installing the
> Alpha?
>  The beta was just released, you could install that directly. Or download the
> newer yum by hand (or comment out the baseurl by hand, from the
> fedora-rawhide.repo file).
> 
>  Jesse, can we just add a conflict on yum < 3.2.22-0 ?  


	
James, never run the update after installing alpha, as it never works. 
think this is a problem in the version of yum?

Greetings
Comment 3 Mariano Roig 2009-04-06 08:34:21 EDT
	
There is something to my attention in the repository FC11 Alpha version of yum is yum-3.2.21-7.
But in the repository is FC11 Beta: yum-3.2.21-16.

There is some problem with the version 3.2.21-7, which have made the downgrade?
Comment 4 James Antill 2009-05-21 09:45:26 EDT
Note that you can get a version of yum that'll be fine with the Fed-11-release from Fed-10 updates-testing.
Comment 5 Fedora Update System 2009-05-21 11:32:14 EDT
yum-3.2.23-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/yum-3.2.23-3.fc10
Comment 6 Fedora Update System 2009-05-21 11:33:59 EDT
yum-3.2.23-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/yum-3.2.23-3.fc11
Comment 7 Fedora Update System 2009-05-25 17:18:12 EDT
yum-3.2.23-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-5328
Comment 8 Fedora Update System 2009-05-25 17:24:54 EDT
yum-3.2.23-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5413
Comment 9 Bug Zapper 2009-06-09 09:14:01 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Fedora Update System 2009-06-15 21:25:40 EDT
yum-3.2.23-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-06-15 21:34:10 EDT
yum-3.2.23-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.