Bug 494118 - Could not load desktop item: libgnome-desktop-2.so.7
Could not load desktop item: libgnome-desktop-2.so.7
Status: CLOSED DUPLICATE of bug 493437
Product: Fedora
Classification: Fedora
Component: gnome-do (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Sindre Pedersen Bjørdal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-04 13:00 EDT by Mads Villadsen
Modified: 2009-04-07 02:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-04 18:23:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Villadsen 2009-04-04 13:00:55 EDT
Description of problem:
When running gnome-do-0.8.1.3-3.fc11.i586 the following error shows up a number of times:

Could not load desktop item: libgnome-desktop-2.so.7

Also when trying to enter Preference the application crashes - apparently due to the same problem with the .so file.

Marshaling button_release_event signal
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.DllNotFoundException: libgnome-desktop-2.so.7
  at (wrapper managed-to-native) Gnome.DesktopItem:gnome_desktop_item_new_from_uri (intptr,int,intptr&)
  at Gnome.DesktopItem.NewFromUri (System.String uri, DesktopItemLoadFlags flags) [0x00000] 
  at Do.Platform.Linux.SystemService.get_AutoStartFile () [0x00000] 
  at Do.Platform.Linux.SystemService.IsAutoStartEnabled () [0x00000] 
  at Do.UI.GeneralPreferencesWidget.get_AutostartEnabled () [0x00000] 
  at Do.UI.GeneralPreferencesWidget..ctor () [0x00000] 
  at Do.UI.PreferencesWindow..ctor () [0x00000] 
  at Do.Core.Controller.ShowPreferences () [0x00000] 
  at Do.Universe.PreferencesItem.Run () [0x00000] 
  at Docky.Interface.Menus.RunnableMenuButtonArgs.Action () [0x00000] 
  at Docky.Interface.Menus.AbstractMenuButtonArgs.HandleButtonReleaseEvent (System.Object o, Gtk.ButtonReleaseEventArgs args) [0x00000] 
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] 
  --- End of inner exception stack trace ---
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] 
  at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] 
  at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x00000] 
  at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00000] 
  at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000] 
  at GLib.Signal.ClosureInvokedCB (System.Object o, GLib.ClosureInvokedArgs args) [0x00000] 
  at GLib.SignalClosure.Invoke (GLib.ClosureInvokedArgs args) [0x00000] 
  at GLib.SignalClosure.MarshalCallback (IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data) [0x00000] 
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at GLib.SignalClosure.MarshalCallback(IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Do.Do.Main(System.String[] args)


Version-Release number of selected component (if applicable):
gnome-do-0.8.1.3-3.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. Start gnome-do from terminal
2. Watch the errors go by
3. Enter Preferences, and get crash
  
Additional info:
Rawhide updated as of 2009-04-04
Comment 1 Sindre Pedersen Bjørdal 2009-04-04 18:23:09 EDT

*** This bug has been marked as a duplicate of bug 493437 ***

Note You need to log in before you can comment on or make changes to this bug.