Bug 494129 - Infinite loop when deleting partitions ?
Infinite loop when deleting partitions ?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-04 17:20 EDT by Mathieu Bridon
Modified: 2009-04-17 09:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 09:17:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log taken during install (36.92 KB, text/plain)
2009-04-06 16:44 EDT, Mathieu Bridon
no flags Details
syslog taken during install (48.02 KB, text/plain)
2009-04-06 16:45 EDT, Mathieu Bridon
no flags Details
storage.log taken during install (25.82 KB, text/plain)
2009-04-06 16:45 EDT, Mathieu Bridon
no flags Details
output of « top -n 10 -b > top_output » during what looks like an infinite loop (51.81 KB, text/plain)
2009-04-06 16:46 EDT, Mathieu Bridon
no flags Details

  None (edit)
Description Mathieu Bridon 2009-04-04 17:20:02 EDT
Description of problem:
When editing partitionning scheme, anaconda presents existing partitions like this:
/dev/sda
  /dev/sda1
  /dev/sda2
  ...

I wanted to delete all partitions, so I deleted each one by clicking on it and then clicking the "delete" button.

It worked fine.

On a second installation, I tried to select the whole disk (/dev/sda) and then click the "delete" button. I was warned that it would delete all partitions on the disk (which is what I expected).

When I validated, the installer hung forever, like it was in a loop on all existing partitions on the disk, except it never stopped.
Comment 1 Mathieu Bridon 2009-04-04 17:33:46 EDT
I forgot to mention that this was with Fedora 11 beta x86_64 DVD.
Comment 2 Chris Lumens 2009-04-06 13:23:25 EDT
Is there any way you can collect more information for us?  We've definitely seen infinite loops in the new partitioning code but I thought we had taken care of them.  If you could attach /tmp/anaconda.log, /tmp/syslog, and /tmp/storage.log to this bug report it would be very helpful.  Also, seeing what processes are running and if anaconda is chewing up all the CPU would be good to know too.  Thanks.
Comment 3 Mathieu Bridon 2009-04-06 16:44:35 EDT
Created attachment 338393 [details]
anaconda.log taken during install
Comment 4 Mathieu Bridon 2009-04-06 16:45:04 EDT
Created attachment 338394 [details]
syslog taken during install
Comment 5 Mathieu Bridon 2009-04-06 16:45:27 EDT
Created attachment 338395 [details]
storage.log taken during install
Comment 6 Mathieu Bridon 2009-04-06 16:46:17 EDT
Created attachment 338397 [details]
output of « top -n 10 -b > top_output » during what looks like an infinite loop
Comment 7 Mathieu Bridon 2009-04-06 16:47:45 EDT
Here are the files you requested.

I'm not sure I took them the proper way. Here is what I did:
1. proceed through install until the « infinite loop »
2. switch VT with CTRL+ALT+F2
3. copy the logs from /tmp and run top while the « infinite loop » is ongoing

If you need something else...
Comment 8 Chris Lumens 2009-04-08 14:48:26 EDT
That's pretty much exactly what I wanted, but it's not clear what's going on based on the output.  How long do you let it sit before deciding it's hung up?  We were having some problems with the display of various wait dialogs and progress bars in the beta that could be interpreted as an infinite loop if you don't let it wait long enough.  Those should be fixed in rawhide.
Comment 9 Mathieu Bridon 2009-04-08 16:02:52 EDT
Just to be sure I didn't over-reacted, I tried it once more just now.

Is 10 minutes enough ? :)

Also, when I switched VT 2 days ago to get the logs and then switched back to the graphical console where anaconda was frozen, the widgets were missing texts, buttons, etc. Just like when a GTK widget is totally frozen in Gnome (not sure I'm making myself clear :-/)

If there's anything else you need...
Comment 10 Chris Lumens 2009-04-09 10:16:53 EDT
Definitely sounds like it's hung, then.  I can't think of any extra information that would help debug this right now.  We will try to reproduce here.
Comment 11 Joel Andres Granados 2009-04-17 09:17:26 EDT
I just tested this with current rawhide (anaconda-11.5.0.45).  Feel free to change status back to assigned if you see this again.

Note You need to log in before you can comment on or make changes to this bug.