Bug 494220 - replace existing system failed
replace existing system failed
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:d9f7cbde716a94109...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-05 14:38 EDT by Jeremy Huddleston
Modified: 2009-04-17 16:18 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 15:57:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (154.88 KB, text/plain)
2009-04-05 14:38 EDT, Jeremy Huddleston
no flags Details
Attached traceback automatically from anaconda. (343.86 KB, text/plain)
2009-04-17 16:18 EDT, Lorenzo Villani
no flags Details

  None (edit)
Description Jeremy Huddleston 2009-04-05 14:38:15 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/lvm.py", line 177, in pvcreate
    raise LVMError("pvcreate failed for %s" % device)
  File "/usr/lib/anaconda/storage/formats/lvmpv.py", line 94, in create
    lvm.pvcreate(self.device)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 276, in execute
    options=self.device.formatArgs)
  File "/usr/lib/anaconda/storage/devicetree.py", line 659, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 210, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 115, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
LVMError: pvcreate failed for /dev/hda8
Comment 1 Jeremy Huddleston 2009-04-05 14:38:19 EDT
Created attachment 338249 [details]
Attached traceback automatically from anaconda.
Comment 2 Jeremy Huddleston 2009-04-05 19:23:17 EDT
I selected 'replace existing system' to reformat my disks.  This failure occurred as it finished formatting.  I then was forced to reboot.  F11's installer then reported disk corruption (and forced a restart) after selecting the language and keyboard layout before selecting the timezone.
Comment 3 Joel Andres Granados 2009-04-09 06:20:23 EDT
We get this error when trying to clean the hd8 partition.  Its a python low level Error.  The same error that prevented the lvm pvcreate action.  The resource was unavailable.
Is this consistently reproducible?  Can you post the output of `parted /dev/hda unit s print free` if you can reproduce.  FWIW I think this bug is due to a specific state of the harddrive.
Comment 4 Jeremy Huddleston 2009-04-09 07:45:20 EDT
Unfortunately, I've worked past this issue.  The F10 installer disk was able to handle the disk's state, so I installed F10, then I was able to upgrade it to F11 using the F11 netinstall disk.
Comment 5 Lorenzo Villani 2009-04-17 16:18:34 EDT
Created attachment 340083 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.