Bug 494260 - Compiz does not work with KDE
Compiz does not work with KDE
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 00:40 EDT by Hasan Ceylan
Modified: 2018-04-11 13:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-14 05:00:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hasan Ceylan 2009-04-06 00:40:31 EDT
Description of problem:
When you switch to compiz WM in KDE, KDE locks up

Version-Release number of selected component (if applicable):
[hceylan@ceylan ~]$ rpm -qa | grep kde | sort                  
compiz-kde-0.7.8-17.fc11.i586                                  
kdeaccessibility-4.2.2-1.fc11.i586                             
kdeartwork-4.2.2-3.fc11.i586
kdebase-4.2.2-2.fc11.i586
kdebase-libs-4.2.2-2.fc11.i586
kdebase-runtime-4.2.2-3.fc11.i586
kdebase-runtime-libs-4.2.2-3.fc11.i586
kdebase-workspace-4.2.2-2.fc11.i586
kdebase-workspace-libs-4.2.2-2.fc11.i586
kdebluetooth-0.3-3.fc11.i586
kdeedu-marble-4.2.2-1.fc11.i586
kde-filesystem-4-25.fc11.noarch
kdegames-4.2.2-3.fc11.i586
kdegames-libs-4.2.2-3.fc11.i586
kdegraphics-4.2.2-3.fc11.i586
kdegraphics-libs-4.2.2-3.fc11.i586
kdelibs3-3.5.10-9.fc11.i586
kdelibs-4.2.2-1.fc11.i586
kdelibs-common-4.2.2-1.fc11.i586
kdemultimedia-4.2.2-2.fc11.i586
kdemultimedia-libs-4.2.2-2.fc11.i586
kdenetwork-4.2.2-1.fc11.i586
kdenetwork-libs-4.2.2-1.fc11.i586
kdepim-4.2.2-2.fc11.i586
kdepim-libs-4.2.2-2.fc11.i586
kdepimlibs-4.2.2-2.fc11.i586
kdepimlibs-akonadi-4.2.2-2.fc11.i586
kdeplasma-addons-4.2.2-2.fc11.i586
kde-plasma-ihatethecashew-0.3-2.fc11.i586
kde-plasma-networkmanagement-0.1-0.8.20090302svn.fc11.i586
kde-plasma-networkmanagement-openvpn-0.1-0.8.20090302svn.fc11.i586
kde-plasma-networkmanagement-vpnc-0.1-0.8.20090302svn.fc11.i586
kde-plasma-quickaccess-0.7.1-8.fc11.i586
kde-plasma-runcommand-1.0-2.fc11.i586
kde-plasma-translatoid-0.6-2.fc11.i586
kde-plasma-weather-1.0.0-3.fc11.i586
kde-settings-4.2-4.20090225svn.fc11.noarch
kde-settings-kdm-4.2-4.20090225svn.fc11.noarch
kde-settings-pulseaudio-4.2-4.20090225svn.fc11.noarch
kdeutils-4.2.2-2.fc11.i586
kdeutils-printer-applet-4.2.2-2.fc11.i586
lockdev-1.0.1-14.fc11.i586
PolicyKit-kde-4.2.0-3.fc11.i586
solar-kde-theme-0.1.17-3.fc11.noarch
system-config-printer-kde-4

[hceylan@ceylan ~]$ rpm -qa | grep compiz | sort
compiz-0.7.8-17.fc11.i586
compiz-bcop-0.7.8-2.fc11.noarch
compizconfig-backend-kconfig-0.7.8-2.fc11.i586
compizconfig-python-0.7.8-3.fc11.i586
compiz-fusion-0.7.8-8.fc11.i586
compiz-fusion-gnome-0.7.8-8.fc11.i586
compiz-kde-0.7.8-17.fc11.i586
compiz-manager-0.6.0-9.fc11.noarch
libcompizconfig-0.7.8-3.fc11.i586


How reproducible:
Everytime

Steps to Reproduce:
1. Install KDE from F11-Beta-Live-KDE
2. [Yum Update To Latest]
3. Install Compiz rpms
4. Either run compiz-manager or switch WM to compiz through the UI

Actual results:
KDE locks up displaying the login screens background

Expected results:
It should work

Additional info:
I have nvidia based laptop Dell Precision M6300 

[hceylan@ceylan ~]$ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HBM (ICH8M-E) LPC Interface Controller (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation Quadro FX 1600M (rev a1)
03:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
03:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
03:01.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
03:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
03:01.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev ff)
09:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5756ME Gigabit Ethernet PCI Express
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
Comment 1 Eddie Lania 2009-04-20 12:32:42 EDT
Running Gnome and on an ATI graphics adapter RV360 (9600XT) it -completely- locks up the desktop too.

compiz-fusion-extras-gnome-0.7.8-6.fc11.i586
compiz-fusion-0.7.8-8.fc11.i586
compiz-fusion-extras-0.7.8-6.fc11.i586
compiz-0.7.8-18.fc11.i586
libcompizconfig-0.7.8-3.fc11.i586
compiz-fusion-gnome-0.7.8-8.fc11.i586
compizconfig-python-0.7.8-3.fc11.i586
compizconfig-backend-gconf-0.7.8-2.fc11.i586
compiz-gnome-0.7.8-18.fc11.i586

xorg-x11-drv-ati-6.12.2-4.fc11.i586

kernel-PAE-2.6.29.1-100.fc11.i686

xorg-x11-server-Xorg-1.6.1-6.fc11.i586
Comment 2 Eddie Lania 2009-04-21 14:36:10 EDT
Hello,

I just wanted to let you know that I changed a few things and now the behaviour when desktop-effects get enabled is different.

First I uninstalled driconf and removed all .drirc files.

Next I removed all compiz settings from ~/.config and ~/.gconf

Now, when I enable desktop effects, the system doesn't lock-up anymore but instead my X session crashes and I am being thrown back to the login screen.

In ~/.xsession-errors.old the following is logged:

gnome-panel: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
nautilus: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
Window manager warning: Fatal IO error 11 (Resource temporarily unavailable) on display ':0.0'.
xfce4-settings-helper: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
seapplet: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
mail-notification: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
nm-applet: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
bluetooth-applet: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
gnome-volume-control-applet: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
gpk-update-icon: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
applet.py: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
gnome-settings-daemon: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
gnome-terminal: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
gnome-power-manager: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.

(gnome-panel:4764): GLib-GObject-CRITICAL **: g_object_run_dispose: assertion `G_IS_OBJECT (object)' failed

(gnome-panel:4764): GLib-GObject-CRITICAL **: g_object_run_dispose: assertion `G_IS_OBJECT (object)' failed
gnome-session: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.


And in /var/log/Xorg.0.log.old:

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x3b) [0x812e40b]
1: /usr/bin/Xorg(xf86SigHandler+0x9e) [0x80c0e0e]
2: [0xc2c400]
3: /usr/lib/dri/r300_dri.so(radeonDestroyBuffer+0x34) [0x429d2d]
4: /usr/lib/dri/r300_dri.so(radeonDestroyContext+0xf4) [0x44bda0]
5: /usr/lib/dri/r300_dri.so [0x423f32]
6: /usr/lib/xorg/modules/extensions//libglx.so [0x19b099]
7: /usr/lib/xorg/modules/extensions//libglx.so(__glXFreeContext+0x91) [0x18f431]
8: /usr/lib/xorg/modules/extensions//libglx.so [0x18f857]
9: /usr/bin/Xorg(CallCallbacks+0x56) [0x808b036]
10: /usr/bin/Xorg(CloseDownClient+0x67) [0x8080fb7]
11: /usr/bin/Xorg(Dispatch+0x1d8) [0x8086698]
12: /usr/bin/Xorg(main+0x3ad) [0x806bb0d]
13: /lib/libc.so.6(__libc_start_main+0xe6) [0xa8a8e6]
14: /usr/bin/Xorg [0x806afa1]

Fatal server error:
Caught signal 11.  Server aborting


Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.


I hope the information is useful.
Comment 3 Eddie Lania 2009-04-21 15:10:52 EDT
Some more information.

It doesn't crash all the time when I enable desktop-effects.

After four times logging in again and trying to enable desktop effects, it suddenly didn't crash. And all worked fine.

But when I log out and back in again it starts crashing again.

Regards,

Eddie.
Comment 4 Eddie Lania 2009-04-22 07:09:40 EDT
Just a little update. When compiz-fusion is enabled using fusion-icon, the screen is not correctly updated and error "settexbuf 1280x1024@4 5120 targ 84f5 format 1401" is in ~/.xsession-errors.

For instance: When open terminal and typing in it, nothing is
show on screen or is corrupted until terminal window is moved. But other windows like browsing files or folders in nautilus show this behaviour too.

And errors like below are constantly being logged in ~/.xsession-errors

ettexbuf 1280x1024@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x25@4 5120 targ 84f5 format 1401
settexbuf 1280x1024@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 37x37@4 192 targ 84f5 format 1401
settexbuf 1280x25@4 5120 targ 84f5 format 1401
settexbuf 37x37@4 192 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x1024@4 5120 targ 84f5 format 1401
settexbuf 1280x25@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 37x37@4 192 targ 84f5 format 1401
settexbuf 1280x1024@4 5120 targ 84f5 format 1401
settexbuf 1280x25@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 37x37@4 192 targ 84f5 format 1401
settexbuf 170x170@4 704 targ 84f5 format 1401
settexbuf 1280x1024@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 37x37@4 192 targ 84f5 format 1401
settexbuf 170x170@4 704 targ 84f5 format 1401

When I don't use the "fusion-icon" program to enable compiz but instead use the "desktop-effects" application, the problem does NOT appear.

When using "desktop-effects" to enable compiz, the garbeled screens are gone and also I do not get the settexbuf errors in the ~/.xsession-errors log.

I do not know what the difference is between enabling compiz through
"fusion-icon" and "desktop-effects" but it clearly makes a big difference.
Comment 5 Matěj Cepl 2009-04-28 06:46:37 EDT
Blaming X driver.
Comment 6 Eddie Lania 2009-05-01 02:40:08 EDT
I cannot start compiz anymore, no matter if I try "desktop-effects" or "fusion-icon". X segfaults and I am being thrown back to the login screen. So, I cannot test anything anymore and I am not really happy about this. When does this get solved?

Apr 29 20:20:22 p3000fedora kernel: Xorg[2153]: segfault at 0 ip 0812e646 sp bffbc198 error 4 in Xorg (deleted)[8047000+1ba000]
Apr 29 20:21:18 p3000fedora kernel: Xorg[23259]: segfault at 0 ip 0812e646 sp bfab4c98 error 4 in Xorg[8047000+1ba000]
Apr 29 20:28:43 p3000fedora kernel: Xorg[24694]: segfault at 0 ip 0812e646 sp bfc86678 error 4 in Xorg[8047000+1ba000]
Apr 29 20:29:14 p3000fedora kernel: Xorg[25340]: segfault at 0 ip 0812e646 sp bfab0c98 error 4 in Xorg[8047000+1ba000]
Apr 29 20:57:12 p3000fedora kernel: Xorg[2035]: segfault at 0 ip 0812e646 sp bfe2f008 error 4 in Xorg[8047000+1ba000]
Apr 30 10:20:04 p3000fedora kernel: Xorg[2030]: segfault at 0 ip 0812e646 sp bfc4ce68 error 4 in Xorg[8047000+1ba000]
Apr 30 10:46:35 p3000fedora kernel: sealert[3673]: segfault at 3a2df6d2 ip 0732eca2 sp bff59490 error 4 in libpython2.6.so.1.0[72ae000+14f000]
Apr 30 22:31:26 p3000fedora kernel: Xorg[2048]: segfault at 0 ip 0812e646 sp bff88968 error 4 in Xorg[8047000+1ba000]
Apr 30 22:32:00 p3000fedora kernel: Xorg[3655]: segfault at 0 ip 0812e646 sp bfa4f438 error 4 in Xorg[8047000+1ba000]
Apr 30 22:32:31 p3000fedora kernel: Xorg[4296]: segfault at 0 ip 0812e646 sp bf86ca58 error 4 in Xorg[8047000+1ba000]
Comment 7 Hasan Ceylan 2009-05-03 19:34:00 EDT
(In reply to comment #5)
> Blaming X driver.  

Is this still valid when desktop-effects working but compiz-manager displays emty screen

Hasan
Comment 8 Eddie Lania 2009-05-04 14:04:01 EDT
Question: according to the policy, current development for f11 has been frozen.
Does this mean this will not be solved before the final f11 release?
Comment 9 Eddie Lania 2009-05-13 13:54:46 EDT
I installed latest Mesa packages and now it all seems to be working fine again.
Comment 10 Matěj Cepl 2009-05-14 05:00:06 EDT
Cool! Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.