Bug 494297 - yum did not install the following packages: perl-Convert-ASN1
yum did not install the following packages: perl-Convert-ASN1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Devan Goodwin
Steve Salevan
:
Depends On:
Blocks: 463876
  Show dependency treegraph
 
Reported: 2009-04-06 04:56 EDT by Jan Pazdziora
Modified: 2009-09-10 14:54 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:54:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2009-04-06 04:56:26 EDT
Description of problem:

When running installer

./install.pl --disconnected --run-updater

on RHEL 5.3, message

Warning: yum did not install the following packages:
	perl-Convert-ASN1

is shown.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090403.2 on i386

How reproducible:

Deterministic.

Steps to Reproduce:
1. Have system registered to RHEL 5 channel.
2. Install Satellite using ./install.pl --run-updater
  
Actual results:

* Applying updates.
* Installing RHN packages.
Warning: more packages were installed by yum than expected:
	libgfortran
Warning: yum did not install the following packages:
	perl-Convert-ASN1
* Now running spacewalk-setup.
* Setting up Oracle environment.
* Setting up database.

Expected results:

* Applying updates.
* Installing RHN packages.
* Now running spacewalk-setup.
* Setting up Oracle environment.
* Setting up database.

Additional info:

Note that we are tracking the libgfortran warning in bug 489854.
Comment 1 Clifford Perry 2009-04-07 11:42:51 EDT
within 520 bug 451980 we removed this from ISO and let it get it from RHN Hosted channels for RHEL. 

Not sure why we are seeing this error now. 

Cliff
Comment 2 Jan Pazdziora 2009-04-08 04:40:57 EDT
On 5.2.0, this package was needed because perl-Convert-PEM required it. This package is now being removed from the ISO via bug 492277, so perl-Convert-ASN1 is no longer needed either and should not be listed in rhelrpms. At least that's how I understand the world to operate.
Comment 3 Devan Goodwin 2009-04-14 10:01:48 EDT
Since 492277 is closed I have removed perl-Convert-ASN1 from rhelrpms in devel cvs:

cvs commit: Examining .
Checking in rhelrpms;
/cvs/devel/rhelfiles/5/RHN-Satellite-5.3/updates/rhelrpms,v  <--  rhelrpms
new revision: 1.4; previous revision: 1.3
done
Comment 4 Steve Salevan 2009-06-03 15:32:44 EDT
VERIFIED on 5/29 build.
Comment 6 Brandon Perkins 2009-09-10 14:54:44 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.