Bug 494315 - Sound Juicer crashes if no MusicBrainz disc ID match
Sound Juicer crashes if no MusicBrainz disc ID match
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sound-juicer (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 07:25 EDT by carl
Modified: 2009-04-14 09:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 09:41:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description carl 2009-04-06 07:25:23 EDT
Description of problem: Sound Juicer crashes when certain CDs are present/inserted. Seems to be CDs whose disc ID is not in MusicBrainz


Version-Release number of selected component (if applicable): 2.26.0-1.fc11


How reproducible: Run Sound Juicer with a CD whose disc ID is not in MusicBrainz


Steps to Reproduce:
1. Insert a CD whose disc ID is not in MusicBrainz
2. Start Sound Juicer, either from the choose action dialog or menu or command line
  
Actual results: displays a blank screen briefly, then terminates


Expected results: displays information from another source, or a list of untitled tracks. Possibly with a message saying the album could not be found in MusicBrainz.


Additional info: Error also occurs if Sound Juicer is running and the disc is inserted.

Once the album is added to MusicBrainz by another means (eg Picard) Sound Juicer loads with no problems.

When run from the command line, the final output is:

** (sound-juicer:1580): CRITICAL **: album_details_free: assertion `album != NULL' failed
Comment 1 Matthias Clasen 2009-04-13 22:25:51 EDT
Can you still reproduce with 2.26.1 ? 
It has a fix for http://bugzilla.gnome.org/show_bug.cgi?id=575820 which looks very similar.
Comment 2 Bastien Nocera 2009-04-14 09:41:38 EDT
I'm pretty certain this is fixed by the latest release. Reopen if not.

Note You need to log in before you can comment on or make changes to this bug.