Bug 494331 - Add option to position panels to grandr
Add option to position panels to grandr
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-applet-grandr (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 08:48 EDT by Jan Wildeboer
Modified: 2013-02-21 07:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 07:47:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Wildeboer 2009-04-06 08:48:22 EDT
Description of problem:

With Intel graphic chipset xrandr usually makes the external port the primary screen, causing the panels to be placed on the wrong screen.

Version-Release number of selected component (if applicable):

All

How reproducible:

Laptop with Intel graphics

Steps to Reproduce:
1. Activate second screen (VGA port)
2. Watch top_panel and bottom_panel go to external screen
  
Actual results:

Panels are non-deterministically placed (from a users POV)

Expected results:

Panels are where the user expects them

Additional info:

I have created a small hack that solves it for me. By using gconftool-2 I force the top_panel and bottom_panel to be on screen #1 in case of external connection.

PROPOSED FEATURE:

Add a simple checkbox to grandr with

"Place panels here"

Suggested workflow: Click on screen, check/uncheck, done

ALTERNATIVE

Dropdown listing all available screens

My hack:

in /usr/local/bin/vgaswitch

#!/bin/sh
xrandr | grep "VGA connected"
if [ $? = 0 ] ; then
  # We have a working VGA connection. Let's use it with fixed 1024x768
  echo "VGA connected, setting VGA to 1024x768 @ 60 Hz"
  # Move the panels to screen #1 as VGA becomes screen #0 due to intel
  /usr/bin/xrandr --output LVDS --auto --output VGA --mode 1024x768 --rate 60 --right-of LVDS
  gconftool-2 --set "/apps/panel/toplevels/bottom_panel/monitor" --type integer "1"
  gconftool-2 --set "/apps/panel/toplevels/top_panel/monitor" --type integer "1"
else
  echo "No VGA connected, back to single screen"
  # All back to the internal screen
  /usr/bin/xrandr --output LVDS --auto --output VGA --off
  gconftool-2 --set "/apps/panel/toplevels/bottom_panel/monitor" --type integer "0"
  gconftool-2 --set "/apps/panel/toplevels/top_panel/monitor" --type integer "0"
fi
Comment 1 Mat Booth 2013-02-21 07:47:02 EST
This package has been retired:

https://fedorahosted.org/rel-eng/ticket/4916

Note You need to log in before you can comment on or make changes to this bug.