Bug 494342 - debug window inform about open file error
debug window inform about open file error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: orsa (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Milos Jakubicek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 09:44 EDT by Marek Mahut
Modified: 2009-04-07 20:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: orsa-0.7.0-7.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 20:24:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Mahut 2009-04-06 09:44:33 EDT
Description of problem:

When orsa is started, debug info window pops up with problem.

Version-Release number of selected component (if applicable):

orsa-0.7.0-5.fc11.i586

How reproducible:

Always

Steps to Reproduce:
1. Start orsa.

Actual results:

[17:42:46][orsa_file.cc:68] Error: Can't open file 

[17:42:46][orsa_file.cc:68] Error: Can't open file 

[17:42:46][orsa_file.cc:1066] Error: Status error!
Comment 1 Milos Jakubicek 2009-04-07 11:59:18 EDT
Actually there are even more complains:

[17:57:50][orsa_file.cc:110] Error: Can't open file /home/milos/.orsa/config
[17:57:50][orsa_file.cc:1416] Error: Status error!
[17:57:50][orsa_file_jpl.cc:76] Error: Can't open JPL ephemeris file []
[17:57:50][orsa_file.cc:68] Error: Can't open file 
[17:57:50][orsa_file.cc:68] Error: Can't open file 
[17:57:50][orsa_file.cc:1066] Error: Status error!

They're completely harmless and are caused by the missing configuration file. Anyway I've added a patch which turns this just into a debug information if the configuration file has not been found.
Comment 2 Milos Jakubicek 2009-04-07 20:24:04 EDT
Fixed in rawhide, I do not find this worth releasing an update for F10/F9...if somebody does (Marek?), please comment here.

Note You need to log in before you can comment on or make changes to this bug.