Bug 494370 - bind init script references obsolete SELinux's booleans and points to wrong booleans.local location
bind init script references obsolete SELinux's booleans and points to wrong b...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bind (Show other bugs)
5.3
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 11:41 EDT by Mauricio Silveira
Modified: 2013-04-30 19:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 03:38:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix path for booleans.local (1.06 KB, patch)
2009-04-06 11:41 EDT, Mauricio Silveira
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 3515 None None None Never

  None (edit)
Description Mauricio Silveira 2009-04-06 11:41:40 EDT
Created attachment 338351 [details]
Fix path for booleans.local

Description of problem:
bind init script /etc/init.d/named has deprecated references to SELinux booleans and wrong reference location to booleans.local

Version-Release number of selected component (if applicable):
5.3

How reproducible: 
Always

Actual results:
/etc/selinux/${SELINUXTYPE}/modules/active/booleans should not be used at all.
Script points to /etc/selinux/${SELINUXTYPE}/booleans.local when the path should be /etc/selinux/${SELINUXTYPE}/modules/active/booleans

Expected results:
Do no try to access /etc/selinux/${SELINUXTYPE}{/,/modules/active}/booleans at all.
Point to /etc/selinux/${SELINUXTYPE}/modules/active/booleans.local instead of /etc/selinux/${SELINUXTYPE}/booleans.local

Additional info:
Patch included
Comment 1 Adam Tkac 2009-04-08 06:42:24 EDT
Both solutions are broken by design, the best solution is to use "getsebool" utility.
Comment 6 errata-xmlrpc 2009-09-02 03:38:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1420.html

Note You need to log in before you can comment on or make changes to this bug.