Bug 494384 - RFE: upgrade to nagios 3.0 in EPEL?
RFE: upgrade to nagios 3.0 in EPEL?
Status: CLOSED CANTFIX
Product: Fedora EPEL
Classification: Fedora
Component: nagios (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
UpdatePackage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 12:52 EDT by Chris Adams
Modified: 2010-11-18 10:36 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-16 07:15:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2009-04-06 12:52:48 EDT
The version of nagios in EPEL for RHEL 5 is 2.12, which is considered "legacy" at this point.  Any chance of upgrading to nagios 3.0 in EPEL, or are we stuck with 2.12 until RHEL 6 (and corresponding EPEL) is out?
Comment 1 Mike McGrath 2009-04-06 12:59:38 EDT
Generally EPEL is considered to be the stable version of these packages.  I often ask "What would RHEL do?" and I'm positive RHEL would stick with the 2.12 branch for at least as long as it's supported upstream, probably longer.

At the same time though, lots of people have been asking for it so I'll take a look at upgrading it.  I'd mentioned it on the epel list not too long ago.
Comment 2 Peter Robinson 2009-09-28 04:25:44 EDT
It looks like the 2.12 branch is no longer supported upstream (I can't see it on the download page at least) and as it doesn't impact anything directly I would think going with the upstream that has the bugfixes and security updates and support would be the better option. RHEL does this with things like pidgin and firefox.
Comment 3 Randall Wood 2010-05-25 08:39:54 EDT
Latest update/release of the 2.12 branch is 19 May 2008, or more than 2 years ago. (http://sourceforge.net/projects/nagios/files/).
Comment 4 Alexandre Frandemiche 2010-08-24 10:04:17 EDT
Hello !

Why this package is not up to date ?

If it's because, 2.12 is more stable than 3.X, why don't make several rpm, one in 2.X and another in 3.X ???

If I can help for make rpm, say to me !

Thanks.
Comment 5 Rob K 2010-10-13 00:32:45 EDT
Yep, this is a blocker for us for EPEL use at the moment, at least without resorting to excludes and pinning. 2.x is long dead.
Comment 6 Peter Lemenkov 2010-11-16 07:15:29 EST
Hello All.
Unfortunately, we can't provide nagios3x for EL-5 since it would be a violation of EPEl policy (major incompatible upgrade).

All I can do for us here, is to provide external repository for those who would like to install nagios3 w/o compiling it (and therefore installing long dependency chain).

http://repos.fedorapeople.org/repos/peter/nagios3/

Feel free to use the packages from this repository - I promise to keep it in sync with EL-6 version.

So far I'm closing this as CANTFIX.
Comment 7 Michael Stahnke 2010-11-18 10:36:42 EST
Could you make a nagios3 package set and have it conflict with nagios?  That's been done for a few other packages already inside of EPEL.

Note You need to log in before you can comment on or make changes to this bug.