This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 494521 - hotspot location ignores the y-coordinate
hotspot location ignores the y-coordinate
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: icon-slicer (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Simon Schampijer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 06:06 EDT by Simon Schampijer
Modified: 2009-05-06 07:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 07:24:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix ignored y-coordinate (1.92 KB, application/octet-stream)
2009-04-07 06:06 EDT, Simon Schampijer
no flags Details

  None (edit)
Description Simon Schampijer 2009-04-07 06:06:56 EDT
Created attachment 338483 [details]
fix ignored y-coordinate

Description of problem:
The index finger pointer has an active point that is at the 2nd and 3rd-finger-knuckle height instead of the extreme fingertip.

For closely-separated text lines with links, the fingertip can be over my desired link, but the lower link will be activated.

The upper edge of the standard pointer holds the active point, so as the pointer image changes, the shift in active point is confusing, and frustrating smooth navigation over the link field.

Version-Release number of selected component (if applicable):
icon-slicer-0.3-11.fc11

How reproducible:
always

Steps to Reproduce:
1. open sugar browse
2. hover slowly over a link until the cursor changes
3. 
  
Actual results:
the pointing finger is already over half of the link
  

Expected results:
the pointing finger should be at the position you were hovering

Additional info:
- bug description in sugar: http://dev.sugarlabs.org/ticket/297

- requested upstream permissions for icon-slicer: http://bugs.freedesktop.org/show_bug.cgi?id=20900

- bug found as well in ubuntu: http://www.mail-archive.com/ubuntu-motu@lists.ubuntu.com/msg05479.html
Comment 1 Simon Schampijer 2009-04-07 06:10:32 EDT
I requested commit access to icon-slicer 10 days ago - but had no success. I am happy to apply the patch myself and build the package. I tested the patched rpm already of course. Of course someone with commit access to do it for me would be more then welcome as well.

Ideally we would get a new upstream release - but this process takes really long as it looks like http://bugs.freedesktop.org/show_bug.cgi?id=20900 and I would like to be on the save side and apply the patch in the meantime.
Comment 2 Matthias Clasen 2009-04-07 13:57:49 EDT
Is your id 'erikos' ? 

I'll see if I can get davidz to approve your commit access. In fact, I bet I can get him to orphan the package, and then you can pick it up if you care about it...
Comment 3 David Zeuthen 2009-04-07 14:07:07 EDT
I have done two things

 - approved requests from user 'erikos'
 - orphaned the package

Simon, feel free to pick up the package. Thanks.
Comment 4 Fedora Admin XMLRPC Client 2009-04-08 03:45:13 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Simon Schampijer 2009-05-06 07:24:53 EDT
Will be fixed in F11.

Note You need to log in before you can comment on or make changes to this bug.