Bug 494524 - Errors during installation of spacewalk-proxy-selinux
Errors during installation of spacewalk-proxy-selinux
Status: CLOSED NOTABUG
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
wes hayutin
:
Depends On:
Blocks: 457079 493428
  Show dependency treegraph
 
Reported: 2009-04-07 06:15 EDT by Miroslav Suchý
Modified: 2009-04-28 05:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 05:36:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2009-04-07 06:15:27 EDT
Description of problem:
# rpm -Uvh /tmp/spacewalk-proxy-selinux-0.5.1-1.noarch.rpm
Preparing...                ########################################### [100%]
   1:spacewalk-proxy-selinux########################################### [100%]
libsepol.permission_copy_callback: Module spacewalk-proxy depends on permission dccp_recv in class node, not satisfied
libsemanage.semanage_link_sandbox: Link packages failed
/usr/sbin/semodule:  Failed!
/sbin/restorecon reset /var/log/rhn/rhn_proxy_broker.log context root:object_r:httpd_log_t:s0->system_u:object_r:var_log_t:s0
/sbin/restorecon reset /var/log/rhn/rhn_proxy_redirect.log context root:object_r:httpd_log_t:s0->system_u:object_r:var_log_t:s0

Version-Release number of selected component (if applicable):
sat530

How reproducible:
done twice

Steps to Reproduce:
1. setenforce 1
2. rpm -Uvh spacewalk-proxy-selinux-0.5.1-1.noarch.rpm
  
Actual results:
libsepol.permission_copy_callback: Module spacewalk-proxy depends on permission dccp_recv in class node, not satisfied
libsemanage.semanage_link_sandbox: Link packages failed
/usr/sbin/semodule:  Failed!

Expected results:
no errors
Comment 1 Jan Pazdziora 2009-04-22 07:46:33 EDT
I don't seem to be able to reproduce this error:

# getenforce 
Enforcing
# rpm -Uvh spacewalk-proxy-selinux-0.5.1-1.el5sat.noarch.rpm
Preparing...                ########################################### [100%]
   1:spacewalk-proxy-selinux########################################### [100%]
/sbin/restorecon reset /var/log/rhn context system_u:object_r:var_log_t:s0->system_u:object_r:spacewalk_log_t:s0
/sbin/restorecon reset /var/spool/rhn-proxy context system_u:object_r:var_spool_t:s0->system_u:object_r:spacewalk_proxy_data_t:s0
# rpm -qa | grep selinux | sort
libselinux-1.33.4-5.1.el5
libselinux-python-1.33.4-5.1.el5
libselinux-utils-1.33.4-5.1.el5
selinux-policy-2.4.6-203.el5
selinux-policy-targeted-2.4.6-203.el5
spacewalk-proxy-selinux-0.5.1-1.el5sat
#

Do you have a machine on which I could try this, or some other clue about what could be different in your setup?
Comment 2 Miroslav Suchý 2009-04-28 05:36:25 EDT
With redhat-release-5Server-5.0.0.9:
# rpm -Uvh spacewalk-proxy-selinux-0.5.1-1.el5sat.noarch.rpm
Preparing...                ########################################### [100%]
   1:spacewalk-proxy-selinux########################################### [100%]
libsepol.permission_copy_callback: Module spacewalk-proxy depends on permission dccp_recv in class node, not satisfied
libsemanage.semanage_link_sandbox: Link packages failed
/usr/sbin/semodule:  Failed!

After upgrade to:
redhat-release-5Server-5.3.0.3
# rpm -Uvh spacewalk-proxy-selinux-0.5.1-1.el5sat.noarch.rpm
Preparing...                ########################################### [100%]
   1:spacewalk-proxy-selinux########################################### [100%]
/sbin/restorecon reset /var/log/rhn context system_u:object_r:var_log_t:s0->system_u:object_r:spacewalk_log_t:s0
/sbin/restorecon reset /var/cache/rhn/proxy-auth context system_u:object_r:var_t:s0->system_u:object_r:spacewalk_proxy_cache_t:s0
/sbin/restorecon reset /var/spool/rhn-proxy context system_u:object_r:var_spool_t:s0->system_u:object_r:spacewalk_proxy_data_t:s0

Since we will requires RHEL5.3 as miminum I'm closing it as not a bug.

Note You need to log in before you can comment on or make changes to this bug.