Bug 494536 - siril segfaults when using "green layer"
siril segfaults when using "green layer"
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: siril (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Marek Mahut
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 07:36 EDT by Marek Mahut
Modified: 2009-08-03 09:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-03 09:09:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (7.16 KB, text/plain)
2009-04-07 07:36 EDT, Marek Mahut
no flags Details

  None (edit)
Description Marek Mahut 2009-04-07 07:36:52 EDT
Created attachment 338489 [details]
backtrace

Description of problem:

Siril segfaults if you try to see "green layer" of open fits file.


Version-Release number of selected component (if applicable):

siril-0.8-6.fc11.i586

How reproducible:

Always

Steps to Reproduce:
1. Open fits file
2. Click on "Green Layer"
3. Kaboom
Comment 1 Lubomir Rintel 2009-04-07 10:06:23 EDT
Fixed in siril-0.8-7.fc11.

The crash seems to be limited to the case when FITS input is not correctly read (see the error console on the left for error messages).

I've been able to reproduce the issue with groundbig2.fits. That file can't be rendered correctly, the patch applied merely prevents the crash. Marek, do you think it should be able to open it? Were you able to open any FITS file?

Furthermore there seem to be problems with strncpy limits, discovered by the most recent gcc 4.4. (sorry for not opening a separate bug). Marek, could you please have a look at those?

http://koji.fedoraproject.org/koji/getfile?taskID=1282854&name=build.log
Comment 2 Bug Zapper 2009-06-09 09:23:59 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Lubomir Rintel 2009-08-03 09:09:59 EDT
Fixed.

Note You need to log in before you can comment on or make changes to this bug.