Bug 494539 - abrt crashes when clicking the "what did you do" entry
abrt crashes when clicking the "what did you do" entry
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 08:13 EDT by David Nielsen
Modified: 2009-12-01 14:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-01 14:10:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2009-04-07 08:13:50 EDT
Description of problem:

Whenever a crash occures abrt captures it, after finishing working a dialog pops up. However when I click the entry to describe what I did. This leads to abrt crashing, which in return causes a request for bug reporting, which again leads to a crash and so on and so forth.

Version-Release number of selected component (if applicable):
abrt-0.0.2-1.fc11.x86_64
abrt-gui-0.0.2-1.fc11.x86_64
python-2.6-7.fc11.x86_64

How reproducible:
100%

abrt handily provides a backtrace for it's own crash, clicking this text box does not lead to a crash.

Core was generated by `/usr/bin/python /usr/share/abrt/CCMainWindow.py'.
Program terminated with signal 11, Segmentation fault.
#0  get_btree (buffer=0x0) at gtktextbuffer.c:789
789	  if (buffer->btree == NULL)
#0  get_btree (buffer=0x0) at gtktextbuffer.c:789
#1  0x00000037f7fd1064 in IA__gtk_text_layout_get_line_yrange (
    layout=0x1146a50, iter=0x7fffd94519d0, y=0x7fffd9451a2c, 
    height=0x7fffd9451a28) at gtktextlayout.c:2827
#2  0x00000037f7fd1142 in IA__gtk_text_layout_set_cursor_visible (
    layout=0x1146a50, cursor_visible=<value optimized out>)
    at gtktextlayout.c:524
#3  0x00000037f7fe17ad in gtk_text_view_focus_in_event (widget=0x1129b80, 
    event=<value optimized out>) at gtktextview.c:4436
#4  0x00000037f7f2fa48 in _gtk_marshal_BOOLEAN__BOXED (closure=0xf63d80, 
    return_value=0x7fffd9451c10, n_param_values=<value optimized out>, 
    param_values=0x1153630, invocation_hint=<value optimized out>, 
    marshal_data=0x37f7fe1780) at gtkmarshalers.c:84
#5  0x0000003edc80b8ee in IA__g_closure_invoke (closure=0xf63d80, 
    return_value=0x7fffd9451c10, n_param_values=2, param_values=0x1153630, 
    invocation_hint=0x7fffd9451bd0) at gclosure.c:767
#6  0x0000003edc821bd0 in signal_emit_unlocked_R (node=0xf63df0, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, 
    instance_and_params=<value optimized out>) at gsignal.c:3282
#7  0x0000003edc8231be in IA__g_signal_emit_valist (instance=0x1129b80, 
    signal_id=<value optimized out>, detail=0, var_args=0x7fffd9451dc0)
    at gsignal.c:2987
#8  0x0000003edc823893 in IA__g_signal_emit (instance=0x0, 
    signal_id=3645184464, detail=19858800) at gsignal.c:3034
#9  0x00000037f8035bdf in gtk_widget_event_internal (widget=0x1129b80, 
    event=0x1248aa0) at gtkwidget.c:4761
#10 0x00000037f8044073 in do_focus_change (widget=0x1129b80, in=1)
    at gtkwindow.c:5250
#11 0x00000037f8044ada in gtk_window_real_set_focus (window=0x131f0c0, 
    focus=0x0) at gtkwindow.c:5475
#12 0x0000003edc80b8ee in IA__g_closure_invoke (closure=0xf6c8b0, 
    return_value=0x0, n_param_values=2, param_values=0x1161560, 
    invocation_hint=0x7fffd9452070) at gclosure.c:767
#13 0x0000003edc821bd0 in signal_emit_unlocked_R (node=0xf6c960, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, 
    instance_and_params=<value optimized out>) at gsignal.c:3282
#14 0x0000003edc8232fe in IA__g_signal_emit_valist (instance=0x131f0c0, 
    signal_id=<value optimized out>, detail=0, var_args=0x7fffd9452260)
    at gsignal.c:2977
#15 0x0000003edc823893 in IA__g_signal_emit (instance=0x0, 
    signal_id=3645184464, detail=19858800) at gsignal.c:3034
#16 0x0000003edc80b8ee in IA__g_closure_invoke (closure=0xf622d0, 
    return_value=0x0, n_param_values=1, param_values=0x115b520, 
    invocation_hint=0x7fffd9452480) at gclosure.c:767
#17 0x0000003edc821bd0 in signal_emit_unlocked_R (node=0xf61760, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, 
    instance_and_params=<value optimized out>) at gsignal.c:3282
#18 0x0000003edc8232fe in IA__g_signal_emit_valist (instance=0x1129b80, 
    signal_id=<value optimized out>, detail=0, var_args=0x7fffd9452670)
    at gsignal.c:2977
#19 0x0000003edc823893 in IA__g_signal_emit (instance=0x0, 
    signal_id=3645184464, detail=19858800) at gsignal.c:3034
#20 0x00000037f803add2 in IA__gtk_widget_grab_focus (widget=0x1129b80)
    at gtkwidget.c:5078
#21 0x00000037f7fe73ab in gtk_text_view_button_press_event (widget=0x0, 
    event=0x7fffd94519d0) at gtktextview.c:4279
#22 0x00000037f7f2fa48 in _gtk_marshal_BOOLEAN__BOXED (closure=0xf628e0, 
    return_value=0x7fffd9452a30, n_param_values=<value optimized out>, 
    param_values=0x118eb00, invocation_hint=<value optimized out>, 
    marshal_data=0x37f7fe7380) at gtkmarshalers.c:84
#23 0x0000003edc80b8ee in IA__g_closure_invoke (closure=0xf628e0, 
    return_value=0x7fffd9452a30, n_param_values=2, param_values=0x118eb00, 
    invocation_hint=0x7fffd94529f0) at gclosure.c:767
#24 0x0000003edc821bd0 in signal_emit_unlocked_R (node=0xf62950, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, 
    instance_and_params=<value optimized out>) at gsignal.c:3282
#25 0x0000003edc8231be in IA__g_signal_emit_valist (instance=0x1129b80, 
    signal_id=<value optimized out>, detail=0, var_args=0x7fffd9452be0)
    at gsignal.c:2987
#26 0x0000003edc823893 in IA__g_signal_emit (instance=0x0, 
    signal_id=3645184464, detail=19858800) at gsignal.c:3034
#27 0x00000037f8035bdf in gtk_widget_event_internal (widget=0x1129b80, 
    event=0x1336470) at gtkwidget.c:4761
#28 0x00000037f7f282c3 in IA__gtk_propagate_event (widget=0x1129b80, 
    event=0x1336470) at gtkmain.c:2396
#29 0x00000037f7f292eb in IA__gtk_main_do_event (event=0x1336470)
    at gtkmain.c:1601
#30 0x00000037f884e7cc in gdk_event_dispatch (source=<value optimized out>, 
    callback=<value optimized out>, user_data=<value optimized out>)
    at gdkevents-x11.c:2364
#31 0x0000003edb83811e in g_main_dispatch (context=<value optimized out>)
    at gmain.c:1814
#32 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2367
#33 0x0000003edb83b878 in g_main_context_iterate (context=0xf3b4a0, 
    block=<value optimized out>, dispatch=<value optimized out>, 
    self=<value optimized out>) at gmain.c:2448
#34 0x0000003edb83bd15 in IA__g_main_loop_run (loop=0x1337bb0) at gmain.c:2656
#35 0x00000037f7eb29bd in IA__gtk_dialog_run (dialog=0x131f0c0)
    at gtkdialog.c:1090
#36 0x00007ffacaee6838 in ?? ()
   from /usr/lib64/python2.6/site-packages/gtk-2.0/gtk/_gtk.so
#37 0x0000003eeaadf2a1 in call_function (oparg=<value optimized out>, 
    pp_stack=<value optimized out>) at Python/ceval.c:3663
#38 PyEval_EvalFrameEx (oparg=<value optimized out>, 
    pp_stack=<value optimized out>) at Python/ceval.c:2370
#39 0x0000003eeaae0805 in fast_function (nk=<value optimized out>, 
    na=<value optimized out>, n=<value optimized out>, 
    pp_stack=<value optimized out>, func=<value optimized out>)
    at Python/ceval.c:3765
#40 call_function (nk=<value optimized out>, na=<value optimized out>, 
    n=<value optimized out>, pp_stack=<value optimized out>, 
    func=<value optimized out>) at Python/ceval.c:3700
#41 PyEval_EvalFrameEx (nk=<value optimized out>, na=<value optimized out>, 
    n=<value optimized out>, pp_stack=<value optimized out>, 
    func=<value optimized out>) at Python/ceval.c:2370
#42 0x0000003eeaae1123 in PyEval_EvalCodeEx (co=0x7ffad1364288, 
    globals=<value optimized out>, locals=<value optimized out>, args=0x0, 
    argcount=<value optimized out>, kws=0x4, kwcount=0, defs=0x0, defcount=0, 
    closure=0x0) at Python/ceval.c:2942
#43 0x0000003eeaa6e67f in function_call (func=0x109b2a8, arg=0x1091788, kw=0x0)
    at Objects/funcobject.c:524
#44 0x0000003eeaa43ce3 in PyObject_Call (func=0x109b2a8, arg=0x7fffd94519d0, 
    kw=0x12f0570) at Objects/abstract.c:2487
#45 0x0000003eeaa5903f in instancemethod_call (func=0x109b2a8, arg=0x1091788, 
    kw=0x0) at Objects/classobject.c:2579
#46 0x0000003eeaa43ce3 in PyObject_Call (func=0x10978c0, arg=0x7fffd94519d0, 
    kw=0x12f0570) at Objects/abstract.c:2487
#47 0x0000003eeaad95f3 in PyEval_CallObjectWithKeywords (func=0x10978c0, 
    arg=0x1087730, kw=0x12f0570) at Python/ceval.c:3548
#48 0x00007ffacb202d50 in ?? ()
   from /usr/lib64/python2.6/site-packages/gtk-2.0/gobject/_gobject.so
#49 0x0000003edc80b8ee in IA__g_closure_invoke (closure=0x11470d0, 
    return_value=0x0, n_param_values=2, param_values=0x12f60b0, 
    invocation_hint=0x7fffd94537f0) at gclosure.c:767
#50 0x0000003edc821f18 in signal_emit_unlocked_R (node=0x10e8640, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, 
    instance_and_params=<value optimized out>) at gsignal.c:3244
#51 0x00007ffacb1fa8be in ?? ()
   from /usr/lib64/python2.6/site-packages/gtk-2.0/gobject/_gobject.so
#52 0x0000003eeaadf473 in call_function (oparg=<value optimized out>, 
    pp_stack=<value optimized out>) at Python/ceval.c:3679
#53 PyEval_EvalFrameEx (oparg=<value optimized out>, 
    pp_stack=<value optimized out>) at Python/ceval.c:2370
#54 0x0000003eeaae1123 in PyEval_EvalCodeEx (co=0xe41cd8, 
    globals=<value optimized out>, locals=<value optimized out>, args=0x0, 
    argcount=<value optimized out>, kws=0x2, kwcount=0, defs=0x0, defcount=0, 
    closure=0x0) at Python/ceval.c:2942
#55 0x0000003eeaa6e77b in function_call (func=0x10111b8, arg=0x1094e60, 
    kw=0x10f1c70) at Objects/funcobject.c:524
#56 0x0000003eeaa43ce3 in PyObject_Call (func=0x10111b8, arg=0x7fffd94519d0, 
    kw=0x12f0570) at Objects/abstract.c:2487
#57 0x0000003eeaadde5b in ext_do_call (nk=<value optimized out>, 
    na=<value optimized out>, flags=<value optimized out>, 
    pp_stack=<value optimized out>, func=<value optimized out>)
    at Python/ceval.c:3978
#58 PyEval_EvalFrameEx (nk=<value optimized out>, na=<value optimized out>, 
    flags=<value optimized out>, pp_stack=<value optimized out>, 
    func=<value optimized out>) at Python/ceval.c:2410
#59 0x0000003eeaae0805 in fast_function (nk=<value optimized out>, 
    na=<value optimized out>, n=<value optimized out>, 
    pp_stack=<value optimized out>, func=<value optimized out>)
    at Python/ceval.c:3765
#60 call_function (nk=<value optimized out>, na=<value optimized out>, 
    n=<value optimized out>, pp_stack=<value optimized out>, 
    func=<value optimized out>) at Python/ceval.c:3700
#61 PyEval_EvalFrameEx (nk=<value optimized out>, na=<value optimized out>, 
    n=<value optimized out>, pp_stack=<value optimized out>, 
    func=<value optimized out>) at Python/ceval.c:2370
#62 0x0000003eeaae1123 in PyEval_EvalCodeEx (co=0x1002030, 
    globals=<value optimized out>, locals=<value optimized out>, args=0x0, 
    argcount=<value optimized out>, kws=0x2, kwcount=0, defs=0x0, defcount=0, 
    closure=0x0) at Python/ceval.c:2942
#63 0x0000003eeaa6e67f in function_call (func=0x1010230, arg=0x1094c20, kw=0x0)
    at Objects/funcobject.c:524
#64 0x0000003eeaa43ce3 in PyObject_Call (func=0x1010230, arg=0x7fffd94519d0, 
    kw=0x12f0570) at Objects/abstract.c:2487
#65 0x0000003eeaa5903f in instancemethod_call (func=0x1010230, arg=0x1094c20, 
    kw=0x0) at Objects/classobject.c:2579
#66 0x0000003eeaa43ce3 in PyObject_Call (func=0x7ffacc2a5730, 
    arg=0x7fffd94519d0, kw=0x12f0570) at Objects/abstract.c:2487
#67 0x0000003eeaa43fb8 in PyObject_CallFunctionObjArgs (
    callable=0x7ffacc2a5730) at Objects/abstract.c:2718
#68 0x00007ffac91455bb in dbus_message_set_reply_serial ()
    at dbus-message.c:894
#69 0x00007ffac914619a in dbus_message_set_reply_serial ()
    at dbus-message.c:894
#70 0x0000003edcc105de in dbus_connection_dispatch (connection=0x10eba20)
    at dbus-connection.c:4406
#71 0x0000003edf0098d5 in message_queue_dispatch (
    source=<value optimized out>, callback=<value optimized out>, 
    user_data=<value optimized out>) at dbus-gmain.c:101
#72 0x0000003edb83811e in g_main_dispatch (context=<value optimized out>)
    at gmain.c:1814
#73 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2367
#74 0x0000003edb83b878 in g_main_context_iterate (context=0xf3b4a0, 
    block=<value optimized out>, dispatch=<value optimized out>, 
    self=<value optimized out>) at gmain.c:2448
#75 0x0000003edb83bd15 in IA__g_main_loop_run (loop=0x1300450) at gmain.c:2656
#76 0x00000037f7f297e7 in IA__gtk_main () at gtkmain.c:1205
#77 0x00007ffacaeff37a in ?? ()
   from /usr/lib64/python2.6/site-packages/gtk-2.0/gtk/_gtk.so
#78 0x0000003eeaadf2a1 in call_function (oparg=<value optimized out>, 
    pp_stack=<value optimized out>) at Python/ceval.c:3663
#79 PyEval_EvalFrameEx (oparg=<value optimized out>, 
    pp_stack=<value optimized out>) at Python/ceval.c:2370
#80 0x0000003eeaae1123 in PyEval_EvalCodeEx (co=0x7ffad1364558, 
    globals=<value optimized out>, locals=<value optimized out>, args=0x0, 
    argcount=<value optimized out>, kws=0x0, kwcount=0, defs=0x0, defcount=0, 
    closure=0x0) at Python/ceval.c:2942
#81 0x0000003eeaae1232 in PyEval_EvalCode (co=0x0, globals=0x7fffd94519d0, 
    locals=0x12f0570) at Python/ceval.c:515
#82 0x0000003eeaafc8dc in run_mod (mod=<value optimized out>, 
    filename=<value optimized out>, globals=0xb53440, locals=0xb53440, 
    flags=<value optimized out>, arena=<value optimized out>)
    at Python/pythonrun.c:1330
#83 0x0000003eeaafc9b0 in PyRun_FileExFlags (fp=0xba79e0, 
    filename=0x7fffd9455b02 "/usr/share/abrt/CCMainWindow.py", 
    start=<value optimized out>, globals=<value optimized out>, 
    locals=0xb53440, closeit=1, flags=0x7fffd9454b80)
    at Python/pythonrun.c:1316
#84 0x0000003eeaafde0e in PyRun_SimpleFileExFlags (fp=<value optimized out>, 
    filename=0x7fffd9455b02 "/usr/share/abrt/CCMainWindow.py", closeit=1, 
    flags=0x7fffd9454b80) at Python/pythonrun.c:926
#85 0x0000003eeab0a8c9 in Py_Main (argc=-784170848, argv=<value optimized out>)
    at Modules/main.c:597
#86 0x0000003eda01e6cd in __libc_start_main (main=<value optimized out>, 
    argc=<value optimized out>, ubp_av=<value optimized out>, 
    init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fffd9454c98)
    at libc-start.c:220
#87 0x0000000000400649 in _start ()
Comment 1 Jiri Moskovcak 2009-04-10 08:40:53 EDT
It seem's more like pygtk problem - reasigning.
Comment 2 Bug Zapper 2009-06-09 09:24:31 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matthew Barnes 2009-06-29 00:55:18 EDT
Seems more like a GTK+ problem actually - reassigning again.
Comment 4 Matthias Clasen 2009-12-01 11:56:25 EST
I can't reproduce this here in F12.

Are you still seeing this ?
Comment 5 David Nielsen 2009-12-01 14:10:21 EST
nope

Note You need to log in before you can comment on or make changes to this bug.