Bug 494540 - satellite-sync -m /... -c rhel-s390x-as-4 failed
satellite-sync -m /... -c rhel-s390x-as-4 failed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Jan Hutař
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-04-07 08:14 EDT by Jan Hutař
Modified: 2009-09-10 16:35 EDT (History)
0 users

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:35:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
after that some test scripts tried to push few packages and I obtained these emails (12.04 KB, application/octet-stream)
2009-04-07 08:14 EDT, Jan Hutař
no flags Details

  None (edit)
Description Jan Hutař 2009-04-07 08:14:45 EDT
Created attachment 338492 [details]
after that some test scripts tried to push few packages and I obtained these emails

Description of problem:
I have tried to sync from nfs://dump-new.rhndev.redhat.com/vol/exportstageprod channel rhel-s390x-as-4 on s390x system, but it failed.


Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL4-re20090401.0/s390x


How reproducible:
1 of 1 attempt


Steps to Reproduce:
1. # satellite-sync --mount-point=/tmp/mount-p20229  -c rhel-s390x-as-4


Actual results:
[...]
07:52:49     254/5997 Extinct package:  tzdata-2008b-3.el4.noarch.rpm
07:52:49     255/5997 Extinct package:  caching-nameserver-7.3-3.0.1.el4_6.noarch.rpm
07:52:49     256/5997 Extinct package:  kernel-doc-2.6.9-67.0.20.EL.noarch.rpm

SYNC ERROR: unhandled exception occurred:

(Check logs/email for potentially more detail)

'module' object has no attribute 'readHeaderFromFD'

+++ sending log as an email +++


Expected results:
sync should work


Additional info:
Email from the satellite I obrained:

From: rhn-satellite@redhat.com
To: jhutar@redhat.com
Subject: RHN Management Satellite sync. report from z212.z900.redhat.com
Date: Tue, 7 Apr 2009 07:52:49 -0400

07:52:49 
SYNC ERROR: unhandled exception occurred:

Exception reported from z212.z900.redhat.com
Time: Tue Apr  7 07:52:49 2009
Exception type exceptions.AttributeError

Exception Handler Information
Traceback (most recent call last):
  File "/usr/bin/satellite-sync", line 142, in main
    return satsync.Runner().main()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 211, in main
    ret = method()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 313, in _step_rpms
    self._packages_report = self.syncer.download_rpms()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 1025, in download_rpms
    self._fetch_packages(channel, missing_fs_packages)
  File "/usr/share/rhn/satellite_tools/satsync.py", line 1857, in _fetch_packages
    hdr = rhn_rpm.get_package_header(filename=rpmManip.full_path)
  File "/usr/share/rhn/common/rhn_rpm.py", line 274, in get_package_header
    hdr, offset = rpm.readHeaderFromFD(file_desc)
AttributeError: 'module' object has no attribute 'readHeaderFromFD'


This happened while running:

http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=53643
Comment 2 Jan Hutař 2009-05-21 08:25:22 EDT
VERIFIED on RHEL5 with 20090507.1 and rhel-i386-as-4:

# satellite-sync -c rhel-i386-as-4 -m /mnt/hostel/export/sputnik-prod/
[...]
14:13:15 Importing channel errata
14:13:38    Importing *relevant* errata: rhel-i386-as-4 (1477)
            ________________________________________
Downloading:######################################## - complete
14:16:25 Importing kickstartable trees (8)
14:16:26 Imported kickstartable trees (8)
    Import complete:
        Begin time: Thu May 21 13:06:20 2009
        End time:   Thu May 21 14:16:26 2009
        Elapsed:    1 hours, 10 minutes, 6 seconds
Comment 4 Brandon Perkins 2009-09-10 16:35:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.