Bug 494584 - Spew of "kmmio: spurrious debug trap ..." messages while running "gdb audacity"
Spew of "kmmio: spurrious debug trap ..." messages while running "gdb audacity"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 10:46 EDT by Tom London
Modified: 2009-04-16 21:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 21:05:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2009-04-07 10:46:02 EDT
Description of problem:
Noticed the following spew generated when I was running "gdb audacity".  Also had rhythmbox/pulseaudio running.

Did not notice that anything "broke"....

System is Thinkpad X200 running fresh rawhide + koji.

Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 1.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 1.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 1.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 1.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 1.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 1.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 1.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 1.
Apr  7 07:24:28 tlondon pulseaudio[3171]: alsa-source.c: Increasing minimal latency to 36.00 ms
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 0.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 1.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 1.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 0.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 0.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 1.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 1.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 1.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 0.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 0.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 0.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 0.
Apr  7 07:24:28 tlondon kernel: kmmio: spurious debug trap on CPU 0.



Version-Release number of selected component (if applicable):
kernel-2.6.29.1-54.fc11.x86_64

How reproducible:
Not sure.....

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dave Jones 2009-04-07 10:59:49 EDT
wtf.. you have mmiotrace enabled somehow.  That should only happen if you explicitly set it up.

Ben, any idea what's going on here?
Comment 2 Ben Skeggs 2009-04-08 01:32:22 EDT
AFAICT it's not actually enabled, that's why it's complaining when it gets the debug trap.  It seems the message is only being shown because the kernel is being built with debugging turned on.
Comment 3 Dave Jones 2009-04-08 11:25:08 EDT
This is kernel-2.6.29.1-54.fc11.x86_64 though, and we turned off debugging in -46

Oh wait, we didn't hook up MMIOTRACE to the 'move to debug' switch in the Makefile. I'll go do that.
Comment 4 Chuck Ebbert 2009-04-10 19:59:13 EDT
Fixed in 2.6.29.1-58
Comment 5 Tom London 2009-04-16 21:05:59 EDT
I can no longer reproduce this.

Closing.

Note You need to log in before you can comment on or make changes to this bug.